summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild')
-rw-r--r--net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild b/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild
index e69352b298c2..68579dd0f39a 100644
--- a/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild
+++ b/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild,v 1.5 2003/05/25 17:34:38 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dyndnsupdate/dyndnsupdate-0.6.14.ebuild,v 1.6 2003/05/26 21:32:44 taviso Exp $
+
+inherit ccc
DESCRIPTION="updates the DNS for your hostname/hostnames and other variables at dyndns.org"
SRC_URI="http://xzabite.org/dyndnsupdate/${P}.tar.gz"
@@ -13,8 +15,8 @@ DEPEND=""
src_compile() {
cp Makefile Makefile.old
- sed -e "s/^\(CFLAGS = \).*/\1$CFLAGS/" \
- -e "s/^\(CC=\)gcc/\1${CC:-gcc}/" Makefile.old > Makefile
+ sed -e "s/^\(CFLAGS = \).*/\1$CFLAGS/" Makefile.old > Makefile
+ is-ccc && replace-cc-hardcode
emake || die "Failed to compile."
}