summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pedro/pedro-1.5.ebuild')
-rw-r--r--net-misc/pedro/pedro-1.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/pedro/pedro-1.5.ebuild b/net-misc/pedro/pedro-1.5.ebuild
new file mode 100644
index 000000000000..2897df9e2ba5
--- /dev/null
+++ b/net-misc/pedro/pedro-1.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pedro/pedro-1.5.ebuild,v 1.1 2010/07/02 23:59:34 keri Exp $
+
+EAPI=1
+
+inherit eutils
+
+DESCRIPTION="Pedro is a subscription/notification communications system"
+HOMEPAGE="http://www.itee.uq.edu.au/~pjr/HomePages/PedroHome.html"
+SRC_URI="http://www.itee.uq.edu.au/~pjr/HomePages/PedroFiles/${P}.tgz
+ doc? ( mirror://gentoo/${PN}-manual-${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-libs/glib:2"
+
+S="${WORKDIR}"/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS README
+
+ if use doc ; then
+ dodoc "${WORKDIR}"/${PN}.pdf
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/examples/*.{c,tcl}
+ doins src/java_api/*.java
+ doins src/python_api/*.py
+ fi
+}