summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/junkbuster/junkbuster-2.0.2-r3.ebuild')
-rw-r--r--net-proxy/junkbuster/junkbuster-2.0.2-r3.ebuild26
1 files changed, 9 insertions, 17 deletions
diff --git a/net-proxy/junkbuster/junkbuster-2.0.2-r3.ebuild b/net-proxy/junkbuster/junkbuster-2.0.2-r3.ebuild
index 7269cdc67eae..d6d510098f4d 100644
--- a/net-proxy/junkbuster/junkbuster-2.0.2-r3.ebuild
+++ b/net-proxy/junkbuster/junkbuster-2.0.2-r3.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/junkbuster/junkbuster-2.0.2-r3.ebuild,v 1.2 2005/07/01 19:49:02 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/junkbuster/junkbuster-2.0.2-r3.ebuild,v 1.3 2005/12/23 23:07:00 vapier Exp $
+
inherit eutils
DESCRIPTION="Filtering HTTP proxy"
@@ -9,36 +10,27 @@ SRC_URI="http://www.waldherr.org/redhat/rpm/srpm/junkbuster-2.0.2-8.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 sparc ppc ~amd64"
+KEYWORDS="~amd64 arm ppc sparc x86"
IUSE=""
-DEPEND="virtual/libc"
+DEPEND=""
S=${WORKDIR}/ijb20
src_unpack() {
unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${P}-fixups.patch
-
- sed -i -e 's:^CFLAGS *=:CFLAGS +=:' ${S}/Makefile
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fixups.patch
}
src_install () {
- dosbin junkbuster
-
- dodir /etc/init.d
- exeinto /etc/init.d
- newexe ${FILESDIR}/junkbuster.rc6 junkbuster
-
- dodir /etc/junkbuster
+ dosbin junkbuster || die
+ newinitd "${FILESDIR}"/junkbuster.rc6 junkbuster
insinto /etc/junkbuster
doins blocklist config cookiefile forward imagelist
- dohtml gpl.html ijbman.html ijbfaq.html
+ dohtml ijbman.html ijbfaq.html
dodoc README README.TOO README.WIN squid.txt
-
doman junkbuster.1
dodir /var/log/junkbuster