summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/madwifi-ng/madwifi-ng-0.9.3.3.ebuild')
-rw-r--r--net-wireless/madwifi-ng/madwifi-ng-0.9.3.3.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/net-wireless/madwifi-ng/madwifi-ng-0.9.3.3.ebuild b/net-wireless/madwifi-ng/madwifi-ng-0.9.3.3.ebuild
new file mode 100644
index 000000000000..514e6f1a4880
--- /dev/null
+++ b/net-wireless/madwifi-ng/madwifi-ng-0.9.3.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng/madwifi-ng-0.9.3.3.ebuild,v 1.1 2007/10/20 22:25:55 steev Exp $
+
+inherit linux-mod
+
+MY_P=${PN/-ng/}-${PV}
+S="${WORKDIR}"/${MY_P}
+
+DESCRIPTION="Next Generation driver for Atheros based IEEE 802.11a/b/g wireless LAN cards"
+HOMEPAGE="http://www.madwifi.org/"
+SRC_URI="mirror://sourceforge/madwifi/madwifi-${PV}.tar.bz2"
+
+LICENSE="atheros-hal
+ || ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="injection"
+
+DEPEND="app-arch/sharutils"
+RDEPEND="!net-wireless/madwifi-old
+ net-wireless/wireless-tools
+ ~net-wireless/madwifi-ng-tools-${PV}"
+
+CONFIG_CHECK="CRYPTO WIRELESS_EXT SYSCTL"
+ERROR_CRYPTO="${P} requires Cryptographic API support (CONFIG_CRYPTO)."
+ERROR_WIRELESS_EXT="${P} requires CONFIG_WIRELESS_EXT selected by Wireless LAN drivers (non-hamradio) & Wireless Extensions"
+ERROR_SYSCTL="${P} requires Sysctl support (CONFIG_SYSCTL)."
+BUILD_TARGETS="all"
+MODULESD_ATH_PCI_DOCS="README"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ MODULE_NAMES='ath_hal(net:"${S}"/ath_hal)
+ wlan(net:"${S}"/net80211)
+ wlan_acl(net:"${S}"/net80211)
+ wlan_ccmp(net:"${S}"/net80211)
+ wlan_tkip(net:"${S}"/net80211)
+ wlan_wep(net:"${S}"/net80211)
+ wlan_xauth(net:"${S}"/net80211)
+ wlan_scan_sta(net:"${S}"/net80211)
+ wlan_scan_ap(net:"${S}"/net80211)
+ ath_rate_amrr(net:"${S}"/ath_rate/amrr)
+ ath_rate_onoe(net:"${S}"/ath_rate/onoe)
+ ath_rate_sample(net:"${S}"/ath_rate/sample)
+ ath_pci(net:"${S}"/ath)'
+
+ BUILD_PARAMS="KERNELPATH=${KV_OUT_DIR}"
+}
+
+src_unpack() {
+ unpack "${A}"
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.9.3-uudecode-gcda-fix.patch
+ if use injection; then epatch "${FILESDIR}"/${PN}-r1886.patch; fi
+ for dir in ath ath_hal net80211 ath_rate ath_rate/amrr ath_rate/onoe ath_rate/sample; do
+ convert_to_m "${S}"/${dir}/Makefile
+ done
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README THANKS docs/users-guide.pdf docs/WEP-HOWTO.txt
+}
+
+pkg_postinst() {
+ local moddir="${ROOT}/lib/modules/${KV_FULL}/net/"
+
+ linux-mod_pkg_postinst
+
+ einfo
+ einfo "Interfaces (athX) are now automatically created upon loading the ath_pci"
+ einfo "module."
+ einfo
+ einfo "The type of the created interface can be controlled through the 'autocreate'"
+ einfo "module parameter."
+ einfo
+ einfo "As of net-wireless/madwifi-ng-0.9.3 rate control module selection is done at"
+ einfo "module load time via the 'ratectl' module parameter. USE flags amrr and onoe"
+ einfo "no longer serve any purpose."
+}