summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'rox-base/rox/rox-2.3.ebuild')
-rw-r--r--rox-base/rox/rox-2.3.ebuild17
1 files changed, 16 insertions, 1 deletions
diff --git a/rox-base/rox/rox-2.3.ebuild b/rox-base/rox/rox-2.3.ebuild
index 45374a321a92..4b58bcc4fe50 100644
--- a/rox-base/rox/rox-2.3.ebuild
+++ b/rox-base/rox/rox-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.3.ebuild,v 1.2 2006/08/15 23:14:16 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.3.ebuild,v 1.3 2006/10/23 14:27:45 lack Exp $
inherit eutils
@@ -18,6 +18,12 @@ KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64"
DEPEND=">=x11-libs/gtk+-2.4
>=dev-libs/libxml2-2.4.23
>=x11-misc/shared-mime-info-0.14
+ >=dev-util/pkgconfig-0.20
+ svg? ( gnome-base/librsvg )"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/libxml2-2.4.23
+ >=x11-misc/shared-mime-info-0.14
svg? ( gnome-base/librsvg )"
IUSE="svg"
@@ -43,8 +49,17 @@ src_compile() {
use sparc && unset PLATFORM
cd ${WORKDIR}/${P}/ROX-Filer
+
+ # Most rox self-compiles have a 'read' call to wait for the user to
+ # press return if the compile fails.
+ # Find and remove this:
+ sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
+
./AppRun --compile || die "make failed"
(cd src; make clean) > /dev/null
+
+ # Restore the original AppRun
+ mv AppRun.bak AppRun
}
src_install() {