summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gerbv/gerbv-1.0.2.ebuild')
-rw-r--r--sci-electronics/gerbv/gerbv-1.0.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-electronics/gerbv/gerbv-1.0.2.ebuild b/sci-electronics/gerbv/gerbv-1.0.2.ebuild
new file mode 100644
index 000000000000..92db6d6aace3
--- /dev/null
+++ b/sci-electronics/gerbv/gerbv-1.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.2.ebuild,v 1.1 2006/08/12 00:26:59 plasmaroo Exp $
+
+inherit eutils
+
+DESCRIPTION="gerbv - The gEDA Gerber Viewer"
+SRC_URI="http://www.geda.seul.org/dist/${P}.tar.gz"
+HOMEPAGE="http://www.geda.seul.org"
+
+IUSE="doc png xinerama"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="=x11-libs/gtk+-2*
+ png? ( media-libs/libpng
+ media-libs/gdk-pixbuf )"
+
+src_compile() {
+ local confOptions
+
+ confOptions='--enable-gtk2'
+ use xinerama && epatch ${FILESDIR}/${PN}-1.0.0-Xinerama.patch
+ use png || confOptions="$confOptions --disable-exportpng"
+
+ econf $confOptions || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+ if use doc; then
+ cd doc
+ dodoc sources.txt
+ use png && dodoc PNG-print/PNGPrintMiniHowto.txt
+ docinto eagle
+ dodoc eagle/eagle2exc*
+ fi
+}