summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/mkgmap/mkgmap-1962.ebuild')
-rw-r--r--sci-geosciences/mkgmap/mkgmap-1962.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-geosciences/mkgmap/mkgmap-1962.ebuild b/sci-geosciences/mkgmap/mkgmap-1962.ebuild
new file mode 100644
index 000000000000..7e004dae3818
--- /dev/null
+++ b/sci-geosciences/mkgmap/mkgmap-1962.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mkgmap/mkgmap-1962.ebuild,v 1.1 2011/06/16 14:37:47 scarabeus Exp $
+
+EAPI=4
+
+JAVA_ANT_ENCODING=UTF-8
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Tool to create garmin maps"
+HOMEPAGE="http://www.mkgmap.org.uk"
+SRC_URI="http://www.mkgmap.org.uk/snapshots/${PN}-r${PV}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${PN}-r${PV}"
+
+src_compile() {
+ eant dist || die
+}
+
+src_install() {
+ java-pkg_newjar "dist/${PN}.jar" || die "java-pkg_newjar failed"
+ java-pkg_dolauncher "${PN}" --jar "${PN}.jar" || die "java-pkg_dolauncher failed"
+
+ dodoc dist/README dist/doc/Credits dist/doc/*.txt
+ doman dist/doc/mkgmap.1
+}