summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/qmatplot/qmatplot-0.4.2-r1.ebuild')
-rw-r--r--sci-visualization/qmatplot/qmatplot-0.4.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-visualization/qmatplot/qmatplot-0.4.2-r1.ebuild b/sci-visualization/qmatplot/qmatplot-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..98bfb672e362
--- /dev/null
+++ b/sci-visualization/qmatplot/qmatplot-0.4.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qmatplot/qmatplot-0.4.2-r1.ebuild,v 1.1 2006/01/29 20:13:57 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="gnuplot-like tool for plotting data sets in either two or three dimensions"
+HOMEPAGE="http://qmatplot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+SLOT="0"
+
+DEPEND="=x11-libs/qt-3*
+ >=sci-mathematics/octave-2.1
+ >=sci-mathematics/scilab-2.6"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}
+
+src_compile() {
+ addwrite "${QTDIR}/etc/settings"
+ econf || die "configure failed"
+ emake QSETTINGSDIR="${QTDIR}/etc/settings/" || die "make failed"
+}
+
+src_install() {
+ make QSETTINGSDIR="${D}/${QTDIR}/etc/settings/" DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog AUTHORS
+}