summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/fbset/fbset-2.1.ebuild')
-rw-r--r--sys-apps/fbset/fbset-2.1.ebuild26
1 files changed, 18 insertions, 8 deletions
diff --git a/sys-apps/fbset/fbset-2.1.ebuild b/sys-apps/fbset/fbset-2.1.ebuild
index 6e9a83eaddaa..cb21242326ba 100644
--- a/sys-apps/fbset/fbset-2.1.ebuild
+++ b/sys-apps/fbset/fbset-2.1.ebuild
@@ -1,24 +1,34 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fbset/fbset-2.1.ebuild,v 1.21 2004/03/02 16:54:32 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fbset/fbset-2.1.ebuild,v 1.22 2004/03/22 03:04:37 vapier Exp $
+
+inherit gcc
-S=${WORKDIR}/${P}
DESCRIPTION="A utility to set the framebuffer videomode"
+HOMEPAGE="http://linux-fbdev.org/"
SRC_URI="http://home.tvd.be/cr26864/Linux/fbdev/${P}.tar.gz"
-HOMEPAGE="http://linux-fbdev.org"
-KEYWORDS="x86 amd64 ppc sparc alpha hppa ia64 ppc64 s390"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc sparc alpha hppa ia64 ppc64 s390"
DEPEND="virtual/glibc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "/^CC =/s:gcc:$(gcc-getCC):" \
+ -e "/^CC =/s:-O2:${CFLAGS}:" \
+ Makefile || die
+}
+
src_compile() {
make || die
}
src_install() {
- dobin fbset modeline2fb
+ dobin fbset modeline2fb || die
doman *.[58]
- dodoc etc/fb.modes.*
- dodoc INSTALL
+ dodoc etc/fb.modes.* INSTALL
}