summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild')
-rw-r--r--sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild24
1 files changed, 20 insertions, 4 deletions
diff --git a/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild b/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild
index 5e09048417a9..4a2c2a40e042 100644
--- a/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild
+++ b/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild,v 1.1 2008/12/04 22:17:14 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild,v 1.2 2008/12/05 21:12:51 cardoe Exp $
+
+inherit multilib
DESCRIPTION="NSS module for name lookups using LDAP"
HOMEPAGE="http://ch.tudelft.nl/~arthur/nss-ldapd/"
@@ -12,11 +14,15 @@ KEYWORDS="~amd64"
IUSE="debug"
DEPEND="net-nds/openldap
+ sasl? ( dev-libs/cyrus-sasl )
+ kerberos? ( virtual/krb5 )
!sys-auth/nss_ldap"
RDEPEND="${DEPEND}"
src_compile() {
+ # nss libraries always go in /lib on Gentoo
econf --enable-warnings --with-ldap-lib=openldap $(use_enable debug) \
+ --libdir=/$(get_libdir) \
|| die "econf failed"
emake || die "emake failed"
}
@@ -24,11 +30,17 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS ChangeLog AUTHORS README
+
# for socket and pid file
- mkdir "${D}"/var/run/nslcd
+ keepdir /var/run/nslcd
# init script
newinitd "${FILESDIR}"/nslcd.rc nslcd
+
+ # make an example copy
+ insinto /usr/share/nss-ldapd
+ doins nss-ldapd.conf
}
pkg_postinst() {
@@ -36,6 +48,10 @@ pkg_postinst() {
elog "For this to work you must configure /etc/nss-ldapd.conf"
elog "This configuration is similar to pam_ldap's /etc/ldap.conf"
elog
- elog "After configuring it, you MUST add `nslcd` to be started"
- elog "i.e. $ rc-update add nslcd default"
+ elog "In order to use nss-ldapd, nslcd needs to be running. You can"
+ elog "start it like this:"
+ elog " # /etc/init.d/nslcd start"
+ elog
+ elog "You can add it to the default runlevel like so:"
+ elog " # rc-update add nslcd default"
}