summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-7.2.ebuild')
-rw-r--r--sys-devel/gdb/gdb-7.2.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/sys-devel/gdb/gdb-7.2.ebuild b/sys-devel/gdb/gdb-7.2.ebuild
index 8cb48290c9af..445bf533ec52 100644
--- a/sys-devel/gdb/gdb-7.2.ebuild
+++ b/sys-devel/gdb/gdb-7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.2.ebuild,v 1.13 2011/08/13 17:49:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.2.ebuild,v 1.14 2011/09/03 14:54:16 grobian Exp $
EAPI="3"
@@ -40,7 +40,7 @@ LICENSE="GPL-2 LGPL-2"
is_cross \
&& SLOT="${CTARGET}" \
|| SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x86-fbsd ~x64-macos ~x86-macos"
IUSE="expat multitarget nls python test vanilla"
RDEPEND=">=sys-libs/ncurses-5.2-r2
@@ -78,7 +78,7 @@ src_configure() {
--disable-werror \
--enable-64-bit-bfd \
--with-system-readline \
- $(is_cross && echo --with-sysroot=/usr/${CTARGET}) \
+ $(is_cross && echo --with-sysroot="${EPREFIX}"/usr/${CTARGET}) \
$(use_with expat) \
$(use_enable nls) \
$(use multitarget && echo --enable-targets=all) \
@@ -98,7 +98,7 @@ src_install() {
# Don't install docs when building a cross-gdb
if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${D}"/usr/share
+ rm -r "${ED}"/usr/share
return 0
fi
@@ -112,10 +112,18 @@ src_install() {
dodoc "${WORKDIR}"/extra/gdbinit.sample
# Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+ rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,standards}.info*
}
pkg_postinst() {
# portage sucks and doesnt unmerge files in /etc
rm -vf "${ROOT}"/etc/skel/.gdbinit
+
+ if use prefix && [[ ${CHOST} == *-darwin* ]] ; then
+ ewarn "gdb is unable to get a mach task port when installed by Prefix"
+ ewarn "Portage, unprivileged. To make gdb fully functional you'll"
+ ewarn "have to perform the following steps:"
+ ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
+ ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
+ fi
}