summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/cryptsetup/cryptsetup-0.1.ebuild')
-rw-r--r--sys-fs/cryptsetup/cryptsetup-0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/cryptsetup/cryptsetup-0.1.ebuild b/sys-fs/cryptsetup/cryptsetup-0.1.ebuild
new file mode 100644
index 000000000000..582c1e079b57
--- /dev/null
+++ b/sys-fs/cryptsetup/cryptsetup-0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="http://www.saout.de/misc/dm-crypt/"
+SRC_URI="http://www.saout.de/misc/dm-crypt/${PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-libs/device-mapper-1.00.07-r1
+ >=dev-libs/libgcrypt-1.1.42"
+
+IUSE=""
+
+S=${WORKDIR}/${PN}-${PV}
+
+pkg_setup() {
+ if ! grep CONFIG_DM_CRYPT /usr/src/linux/.config > /dev/null 2>&1
+ then
+ ewarn "dm-crypt is not enabled in /usr/src/linux/.config"
+ ewarn "please see $HOMEPAGE"
+ ewarn "for details on how to enable dm-crypt for your kernel"
+ fi
+}
+
+src_compile() {
+ cd ${S}
+
+ econf --bindir=/bin --disable-nls|| die
+
+ sed -i -e 's|-lgcrypt|/usr/lib/libgcrypt.a|' Makefile src/Makefile
+ sed -i -e 's|-lgpg-error|/usr/lib/libgpg-error.a|' Makefile src/Makefile
+ sed -i -e 's|-lpopt|/usr/lib/libpopt.a|' src/Makefile
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install
+}