summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/evms/evms-2.3.4.ebuild')
-rw-r--r--sys-fs/evms/evms-2.3.4.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/sys-fs/evms/evms-2.3.4.ebuild b/sys-fs/evms/evms-2.3.4.ebuild
new file mode 100644
index 000000000000..248bf4150b5f
--- /dev/null
+++ b/sys-fs/evms/evms-2.3.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/evms/evms-2.3.4.ebuild,v 1.1 2004/06/09 07:36:59 eradicator Exp $
+
+IUSE="ncurses gtk"
+
+inherit eutils
+
+DESCRIPTION="Utilities for the IBM Enterprise Volume Management System"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.sourceforge.net/projects/evms"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 -ppc -sparc -alpha -hppa -mips"
+
+#EVMS uses libuuid from e2fsprogs
+DEPEND="virtual/glibc
+ sys-fs/e2fsprogs
+ sys-libs/device-mapper
+ gtk? ( =x11-libs/gtk+-1* )
+ ncurses? ( sys-libs/ncurses )"
+
+src_compile() {
+ local excluded_interfaces=""
+ use ncurses || excluded_interfaces="--disable-text-mode"
+ use gtk || excluded_interfaces="${excluded_interfaces} --disable-gui"
+
+ econf \
+ --libdir=/lib \
+ --sbindir=/sbin \
+ --includedir=/usr/include \
+ ${excluded_interfaces} || die "Failed configure"
+ emake || die "Failed emake"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Make install died"
+ dodoc ChangeLog COPYING INSTALL* PLUGIN.IDS README TERMINOLOGY doc/linuxrc
+
+ # install the sample configuration into the doc dir
+ dodoc ${D}/etc/evms.conf.sample
+ rm -f ${D}/etc/evms.conf.sample
+
+ # the kernel patches may come handy for people compiling their own kernel
+ docinto kernel/2.4
+ dodoc kernel/2.4/*
+ docinto kernel/2.6
+ dodoc kernel/2.6/*
+
+ # move static libraries to /usr/lib
+ dodir /usr/lib
+ mv -f ${D}/lib/*.a ${D}/usr/lib
+
+ # Create linker scripts for dynamic libs in /lib, else gcc
+ # links to the static ones in /usr/lib first. Bug #4411.
+ for x in ${D}/usr/lib/*.a
+ do
+ if [ -f ${x} ]
+ then
+ local lib="${x##*/}"
+ gen_usr_ldscript ${lib/\.a/\.so}
+ fi
+ done
+
+ # the gtk+ frontend should live in /usr/sbin
+ if [ -n "`use gtk`" ]
+ then
+ dodir /usr/sbin
+ mv -f ${D}/sbin/evmsgui ${D}/usr/sbin
+ fi
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/evms2-init evms
+}
+
+pkg_postinst() {
+
+ ewarn "Presently gentoo-sources-2.4.22 has basic support for evms2,"
+ ewarn "but does NOT support some of the more advanced features."
+}