summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild')
-rw-r--r--sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild b/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild
index 568f75e6aa1f..708e3c181dad 100644
--- a/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild
+++ b/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild,v 1.1 2003/05/13 18:49:07 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/compaq-sources/compaq-sources-2.4.9.32.7.ebuild,v 1.2 2003/09/07 07:26:00 msterret Exp $
ETYPE="sources"
inherit kernel
@@ -15,41 +15,41 @@ S=${WORKDIR}/linux-${KV}
# -taviso <taviso@gentoo.org>
#
-DEPEND="${DEPEND}
+DEPEND="${DEPEND}
app-arch/rpm2targz
>=sys-apps/sed-4"
REDPEND=""
DESCRIPTION="Kernel from the Compaq Distribution of Red Hat Linux (ALPHA)."
SRC_URI="ftp://ftp2.compaq.com/pub/linux/RedHat/7.2-alpha/updates/rpms/alpha/kernel-source-${KV}.alpha.rpm"
-HOMEPAGE="http://www.kernel.org/ http://www.redhat.com/ http://www.support.compaq.com/alpha-tools/redhat/"
+HOMEPAGE="http://www.kernel.org/ http://www.redhat.com/ http://www.support.compaq.com/alpha-tools/redhat/"
KEYWORDS="-* ~alpha"
SLOT="${KV}"
src_unpack() {
local kernel_rpm="kernel-source-${KV}.alpha.rpm"
cd ${WORKDIR}
-
+
ebegin "Unpacking Distribution RPM..."
-
+
# agriffis' fast+efficient rpm extraction method from
# the dev-lang/ccc ebuild.
- #
+ #
i=${DISTDIR}/${kernel_rpm}
dd ibs=`rpmoffset < ${i}` skip=1 if=$i 2>/dev/null \
| gzip -dc | cpio -idmu 2>/dev/null \
&& find usr -type d -print0 | xargs -0 chmod a+rx
eend ${?}
assert "Failed to extract ${kernel_rpm%.rpm}.tar.gz"
-
+
mv usr/src/linux-${KV} ${WORKDIR}
- cd ${S}
-
+ cd ${S}
+
# just fix a couple of minor issues...
sed -i 's#include/linux/autoconf.h \(include/linux/version.h \\\)#\1#' Makefile
sed -i 's#\(extern\) \(unsigned long irq_err_count;\)#\1 volatile \2#' arch/alpha/kernel/irq_alpha.c
- sed -i 's#/DISCARD/ : { \*(.text.exit)#/DISCARD/ : {#' arch/alpha/vmlinux.lds.in
-
+ sed -i 's#/DISCARD/ : { \*(.text.exit)#/DISCARD/ : {#' arch/alpha/vmlinux.lds.in
+
# hand it over to the eclass...
kernel_universal_unpack
}
@@ -62,7 +62,7 @@ pkg_postinst () {
einfo "extensively tested, and used by many thousands. This kernel will include"
einfo "bugfixes and extended hardware support, and is probably the most widely"
einfo "used Linux kernel on the Alpha Platform today."
- einfo
+ einfo
ewarn "DO NOT Report issues with this kernel to Red Hat or Compaq, use"
ewarn "the Gentoo Linux bugzilla at http://bugs.gentoo.org/"
einfo