summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.6.19.2-r2.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.19.2-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.19.2-r2.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.19.2-r2.ebuild
new file mode 100644
index 000000000000..b049be9a2871
--- /dev/null
+++ b/sys-kernel/linux-headers/linux-headers-2.6.19.2-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.19.2-r2.ebuild,v 1.1 2007/01/28 23:55:06 vapier Exp $
+
+ETYPE="headers"
+H_SUPPORTEDARCH="alpha amd64 arm cris hppa m68k mips ia64 ppc ppc64 s390 sh sparc x86"
+inherit kernel-2
+detect_version
+
+PATCH_VER="3"
+SRC_URI="mirror://gentoo/gentoo-headers-base-${PV}.tar.bz2"
+[[ -n ${PATCH_VER} ]] && SRC_URI="${SRC_URI} mirror://gentoo/gentoo-headers-${PV}-${PATCH_VER}.tar.bz2"
+
+KEYWORDS="-* ~alpha ~amd64 arm ~hppa ~ia64 m68k ~ppc ~ppc64 s390 sh ~sparc ~x86"
+
+DEPEND="dev-util/unifdef"
+RDEPEND=""
+
+S=${WORKDIR}/gentoo-headers-base-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
+}
+
+src_test() {
+ make ARCH=$(tc-arch-kernel) headers_check || die
+}