summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/com_err/files/com_err-1.37-makefile.patch')
-rw-r--r--sys-libs/com_err/files/com_err-1.37-makefile.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-libs/com_err/files/com_err-1.37-makefile.patch b/sys-libs/com_err/files/com_err-1.37-makefile.patch
index 57dcee4a20b2..b60ea5a37677 100644
--- a/sys-libs/com_err/files/com_err-1.37-makefile.patch
+++ b/sys-libs/com_err/files/com_err-1.37-makefile.patch
@@ -34,3 +34,14 @@ Don't use target LDFLAGS/CFLAGS when compiling native apps.
gen-tarball: $(srcdir)/gen-tarball.in $(top_builddir)/config.status
@echo " CONFIG.STATUS $@"
+--- lib/Makefile.elf-lib
++++ lib/Makefile.elf-lib
+@@ -26,7 +26,7 @@
+
+ $(ELF_LIB): $(OBJS)
+ @echo " GEN_ELF_SOLIB $(ELF_LIB)"
+- @(cd elfshared; $(CC) --shared -o $(ELF_LIB) \
++ @(cd elfshared; $(CC) --shared -o $(ELF_LIB) $(LDFLAGS) \
+ -Wl,-soname,$(ELF_SONAME) $(OBJS) $(ELF_OTHER_LIBS))
+ @$(MV) elfshared/$(ELF_LIB) .
+ @$(RM) -f ../$(ELF_LIB) ../$(ELF_IMAGE).so ../$(ELF_SONAME)