summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.6-r2.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r2.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r2.ebuild b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
index 059a7f101660..821349f3cfae 100644
--- a/sys-libs/glibc/glibc-2.3.6-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.10 2006/01/18 21:09:11 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.11 2006/01/24 00:41:36 vapier Exp $
# TODO:
# - fix warning from glibc build system:
@@ -626,6 +626,13 @@ alt_headers() {
fi
echo "${ALT_HEADERS}"
}
+alt_build_headers() {
+ if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
+ ALT_BUILD_HEADERS=$(alt_headers)
+ tc-is-cross-compiler && ALT_BUILD_HEADERS=${ROOT}${headersloc}
+ fi
+ echo "${ALT_BUILD_HEADERS}"
+}
alt_prefix() {
if is_crosscompile ; then
@@ -743,7 +750,7 @@ setup_flags() {
}
check_kheader_version() {
- local header="${ROOT}$(alt_headers)/linux/version.h"
+ local header="$(alt_build_headers)/linux/version.h"
[[ -z $1 ]] && return 1
@@ -953,8 +960,6 @@ glibc_do_configure() {
fi
# Pick out the correct location for build headers
- local headersloc=$(alt_headers)
- tc-is-cross-compiler && headersloc=${ROOT}${headersloc}
myconf="${myconf}
--without-cvs
--enable-bind-now
@@ -962,7 +967,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
--without-gd
- --with-headers=${headersloc}
+ --with-headers=$(alt_build_headers)
--prefix=$(alt_prefix)
--mandir=$(alt_prefix)/share/man
--infodir=$(alt_prefix)/share/info