summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/hardened-glibc/Manifest1
-rw-r--r--sys-libs/hardened-glibc/hardened-glibc-2.6.1.ebuild143
2 files changed, 0 insertions, 144 deletions
diff --git a/sys-libs/hardened-glibc/Manifest b/sys-libs/hardened-glibc/Manifest
index b913075faf77..0a7c42a3538b 100644
--- a/sys-libs/hardened-glibc/Manifest
+++ b/sys-libs/hardened-glibc/Manifest
@@ -2,6 +2,5 @@ DIST glibc-2.6.1-GENTOOPATCHES.patch.gz 829226 RMD160 c1a2586d3698d70d497213762e
DIST glibc-2.6.1-LOCALEGEN_NSCD.patch.gz 8354 RMD160 583781b729108718a234f1ea7b38ca84f41728b0 SHA1 c735e59c610e5e994c8543d8e5dfbfd65d2ae987 SHA256 9cfbdc04efe0437c96dd6e1066c27366cb7f17715d2a5cb945fc46ab4a881cb7
DIST glibc-2.6.1.tar.bz2 15767401 RMD160 a58226e394780a6996d608febf5881134990919e SHA1 85573fee8d79180165e9466a1fc25133b5792190 SHA256 3ded3a3c3ba2cf02d72479a5cc0829c7c261a9d0934e49a79233de9fa276ec22
EBUILD hardened-glibc-2.6.1-r1.ebuild 4768 RMD160 1405a9b2a34b3f20506a414be014855e68cf0754 SHA1 3b37317896309b081bfc451458b4d05d3530f575 SHA256 6d4dfe4a369efce030c3fd1524e0a93ed59cfc58a7a6a9d88ac8d1e31d7dddcb
-EBUILD hardened-glibc-2.6.1.ebuild 3734 RMD160 edbde93f56e5287eb48e972b13f4629bfc12bcc3 SHA1 770614adf84e12da34cb82b94a8f8207e9129540 SHA256 be4618a7174d292402a74f146368ad4c801162bb11319ea252deafb50222243d
MISC ChangeLog 701 RMD160 c46bb3b0d639f2eafaabfdef651aaafba4910433 SHA1 ab21dbb0c4c92f3e9868c3008212ec0362225873 SHA256 9c90c0baa905ac02b281af7953ca4caf0c19c07f6ad501a1aa0a925bfc519c42
MISC metadata.xml 161 RMD160 600015e5b2643ae38ea2f9e5aaff6d31d42470a8 SHA1 578b6ea4c02d377eb40ee4000df8bc3d97497f82 SHA256 f9146563cc3df2b0d02d2f554c5293d439b56a4d36bc5aed0c66aa83dfb06c2f
diff --git a/sys-libs/hardened-glibc/hardened-glibc-2.6.1.ebuild b/sys-libs/hardened-glibc/hardened-glibc-2.6.1.ebuild
deleted file mode 100644
index 881556385cdc..000000000000
--- a/sys-libs/hardened-glibc/hardened-glibc-2.6.1.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/hardened-glibc/hardened-glibc-2.6.1.ebuild,v 1.2 2008/04/27 23:17:42 pappy Exp $
-
-inherit eutils
-
-# the main installation routine and patches
-# from http://www.linuxfromscratch.org/hlfs
-# and one file of patches of sys-libs/glibc
-
-DESCRIPTION="Gentoo Hardened GNU libc6"
-HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
-
-KERNELVER="2.6.18"
-
-GNU_MIRROR="ftp://ftp.gnu.org/gnu"
-
-PATCHDIST="http://dev.gentoo.org/~pappy/dist/hardened"
-PATCHPATH="sys-libs/hardened-glibc/files/${PV}"
-GENTOOPATCHES="glibc-${PV}-GENTOOPATCHES.patch.gz"
-
-SRC_URI="${SRC_URI} \
- ${GNU_MIRROR}/glibc/glibc-${PV}.tar.bz2"
-SRC_URI="${SRC_URI} \
- ${PATCHDIST}/${PATCHPATH}/${GENTOOPATCHES}"
-
-LICENSE="LGPL-2"
-SLOT="1"
-
-# only works for x86 so far
-# test version, do not use
-# will disappear from portage soon again
-KEYWORDS="-x86"
-IUSE=""
-
-PROVIDE="virtual/libc"
-RESTRICT="strip" #46186
-
-pkg_setup() {
- # hardcoding the CHOST in this ebuild (for x86 stages)
- export CHOST="i486-pc-linux-gnu"
- export CFLAGS="-O2 -pipe"
- export CXXFLAGS="${CFLAGS}"
-
- export CPPFLAGS=""
- export ASFLAGS=""
- export LDFLAGS=""
-
- if [[ "x${MAKEOPTS}y" == "xy" ]]
- then
- export MAKEOPTS="-j4"
- fi
-
- einfo "using CHOST:${CHOST}"
- einfo "using C(XX)FLAGS:${CFLAGS}:${CXXFLAGS}"
- einfo "using MAKEOPTS:${MAKEOPTS}"
-}
-
-src_compile() {
- cd "${WORKDIR}/glibc-${PV}"
-
- epatch "${WORKDIR}/glibc-${PV}-GENTOOPATCHES.patch"
-
- mkdir -p "${WORKDIR}/glibc-build"
- cd "${WORKDIR}/glibc-build"
-
- "${WORKDIR}/glibc-${PV}/configure" \
- --target="${CHOST}" \
- --prefix=/usr \
- --enable-bind-now \
- --without-gd \
- --disable-profile \
- --enable-add-ons=nptl \
- --without-selinux \
- --with-tls \
- --with-__thread \
- --enable-kernel="${KERNELVER}" \
- --without-cvs || die "configuration failed"
-
- make || die "compile failed"
-}
-
-src_install() {
- cd "${WORKDIR}/glibc-build"
-
- make install_root="${D}" install || die "make install failed"
-
- # NOTE: for installing all glibc locales in the binpackage,
- # NOTE: make install_root="${D}" localedata/install-locales
-
- insinto /etc
-
- local configfiles="${WORKDIR}/glibc-${PV}/gentoo"
-
- # install the locale-gen helper utility and config file
- dosbin "${configfiles}/locale/locale-gen" || \
- die "locale-gen helper script could not be installed"
-
- doins "${configfiles}/locale/locale.gen" || \
- die "locale.gen config file could not be installed"
-
- # install the nscd startup script
- doinitd "${configfiles}/etc/nscd" || \
- die "nscd run level startup script could not be installed"
-
- # install the config files for glibc
- doins "${configfiles}"/etc/*.conf || \
- die "glibc config files could not be installed"
-
- # make sure the localtime is not overwritten by glibc emerges
- rm "${D}/etc/localtime"
-}
-
-# NOTE: the locales are not in the .tbz2 file of the binpackage
-# NOTE: but will be generated in the postinst routine from here
-pkg_postinst() {
- # make sure the file exists on the installed system
- touch "${ROOT}/ld.so.conf"
-
- # install locales (logic taken from sys-libs/glibc)
- local locale_list="${ROOT}/etc/locale.gen"
- if [[ -z $(locale-gen --list --config "${locale_list}") ]]
- then
- locale_list="${ROOT}/usr/share/i18n/SUPPORTED"
- fi
-
- # find the number of jobs available
- local x jobs
- for x in ${MAKEOPTS} ; do [[ "${x}" == -j* ]] && jobs=${x#-j} ; done
-
- # generate the locales
- locale-gen -j ${jobs:-2} --config "${locale_list}"
-
- # set the timezone automatically if not found
- if [[ ! -f "${ROOT}/etc/localtime" ]]
- then
- einfo "timezone not found: setting timezone to UTC"
- cp --remove-destination \
- "${ROOT}/usr/share/zoneinfo/UTC" \
- "${ROOT}/etc/localtime"
- fi
-}
-