summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/glances/glances-1.4.ebuild')
-rw-r--r--sys-process/glances/glances-1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-process/glances/glances-1.4.ebuild b/sys-process/glances/glances-1.4.ebuild
new file mode 100644
index 000000000000..f614a4962e4c
--- /dev/null
+++ b/sys-process/glances/glances-1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/glances/glances-1.4.ebuild,v 1.1 2012/09/05 14:36:58 xarthisius Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="CLI curses based monitoring tool"
+HOMEPAGE="https://github.com/nicolargo/glances/blob/master/README.md
+http://pypi.python.org/pypi/Glances"
+SRC_URI="https://github.com/downloads/nicolargo/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/psutil-0.4.1"
+
+src_prepare() {
+ sed -e "s:share/doc/glances:share/doc/${PF}:g" \
+ -e "/COPYING/d" -i setup.py || die
+ distutils_src_prepare
+}