summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_wsgi/mod_wsgi-2.6.ebuild')
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-2.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/www-apache/mod_wsgi/mod_wsgi-2.6.ebuild b/www-apache/mod_wsgi/mod_wsgi-2.6.ebuild
new file mode 100644
index 000000000000..f884e0902093
--- /dev/null
+++ b/www-apache/mod_wsgi/mod_wsgi-2.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_wsgi/mod_wsgi-2.6.ebuild,v 1.1 2009/11/07 17:51:05 arfrever Exp $
+
+EAPI="2"
+
+inherit apache-module
+
+DESCRIPTION="An Apache2 module for running Python WSGI applications."
+HOMEPAGE="http://code.google.com/p/modwsgi/"
+SRC_URI="http://modwsgi.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3[threads]"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="WSGI"
+
+DOCFILES="README"
+
+need_apache2
+
+src_configure() {
+ econf --with-apxs=${APXS}
+}
+
+src_compile() {
+ emake || die "emake failed"
+}