summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_wsgi/mod_wsgi-3.5.ebuild')
-rw-r--r--www-apache/mod_wsgi/mod_wsgi-3.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-apache/mod_wsgi/mod_wsgi-3.5.ebuild b/www-apache/mod_wsgi/mod_wsgi-3.5.ebuild
new file mode 100644
index 000000000000..1aa4f495c17d
--- /dev/null
+++ b/www-apache/mod_wsgi/mod_wsgi-3.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_wsgi/mod_wsgi-3.5.ebuild,v 1.1 2014/05/26 08:15:16 djc Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_6 python2_7 python3_2 python3_3 )
+PYTHON_REQ_USE="threads"
+
+inherit apache-module eutils python-single-r1
+
+DESCRIPTION="An Apache2 module for running Python WSGI applications."
+HOMEPAGE="http://code.google.com/p/modwsgi/"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APACHE2_MOD_CONF="70_${PN}"
+APACHE2_MOD_DEFINE="WSGI"
+
+DOCFILES="README"
+
+need_apache2
+
+src_configure() {
+ econf --with-apxs=${APXS} --with-python=${PYTHON}
+}
+
+src_compile() {
+ default
+}