summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/nikola/nikola-3.ebuild')
-rw-r--r--www-apps/nikola/nikola-3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-apps/nikola/nikola-3.ebuild b/www-apps/nikola/nikola-3.ebuild
new file mode 100644
index 000000000000..32b223c8b5bc
--- /dev/null
+++ b/www-apps/nikola/nikola-3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/nikola-3.ebuild,v 1.1 2012/06/27 08:07:33 yngwin Exp $
+
+EAPI=4
+PYTHON_COMPAT="python2_6 python2_7"
+
+inherit python-distutils-ng
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="http://nikola.ralsina.com.ar/"
+SRC_URI="http://nikola-generator.googlecode.com/files/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/docutils
+ dev-python/doit
+ dev-python/imaging
+ >=dev-python/mako-0.6
+ dev-python/pygments"
+
+src_install() {
+ python-distutils-ng_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm "${D}"/usr/*.txt
+
+ dodoc README.md docs/*
+}