summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/open-xchange/open-xchange-0.8.1.5.ebuild')
-rw-r--r--www-apps/open-xchange/open-xchange-0.8.1.5.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/www-apps/open-xchange/open-xchange-0.8.1.5.ebuild b/www-apps/open-xchange/open-xchange-0.8.1.5.ebuild
index be364fbf0357..4c1491a9e374 100644
--- a/www-apps/open-xchange/open-xchange-0.8.1.5.ebuild
+++ b/www-apps/open-xchange/open-xchange-0.8.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/open-xchange/open-xchange-0.8.1.5.ebuild,v 1.1 2005/11/30 22:46:20 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/open-xchange/open-xchange-0.8.1.5.ebuild,v 1.2 2005/11/30 22:48:34 eradicator Exp $
inherit eutils webapp ssl-cert toolchain-funcs java-pkg versionator depend.apache
@@ -313,8 +313,7 @@ src_install() {
if has_version '<www-servers/tomcat-5.0.28-r4' ; then
dosed 's:tomcat-5:tomcat5:' /etc/init.d/open-xchange
fi
-
-
+
insinto ${SERVLETDIR}
doins lib/*.war
@@ -342,7 +341,7 @@ src_install() {
dosym ../../../etc/openldap/schema/openxchange.schema /usr/share/open-xchange/openxchange.schema
dosym ../../openldap/ldap.conf /etc/open-xchange/groupware/ldap.conf
dosym ../../openldap/ldap.conf /etc/open-xchange/webmail/ldap.conf
-
+
if use ssl ; then
#create symlink to ssl directory for webmail
dosym /etc/open-xchange/groupware/sslcerts /etc/open-xchange/webmail/sslcerts
@@ -350,7 +349,7 @@ src_install() {
dodir ${TOMCAT_SHARED_LIB}
dosym /usr/lib/open-xchange/liboxssl.so ${TOMCAT_SHARED_LIB}/liboxssl.so
fi
-
+
for x in settings/intranet settings/webmail filespool drafts webmailupload dictionary ; do
keepdir /var/open-xchange/${x}
fowners tomcat:tomcat /var/open-xchange/${x}
@@ -363,7 +362,7 @@ src_install() {
# copy ldap-aci-file
insinto /etc/openldap/
doins ${FILESDIR}/slapd.ox.inc
-
+
# copy sql update file
insinto /usr/share/open-xchange/
doins ${FILESDIR}/ox_reminder.sql
@@ -417,7 +416,7 @@ pkg_preinst(){
rm ${D}/etc/open-xchange/groupware/sslcerts/oxCERTS/groupware.pem
rm ${D}/etc/open-xchange/groupware/sslcerts/oxCERTS/sessiond.csr
rm ${D}/etc/open-xchange/groupware/sslcerts/oxCERTS/groupware.csr
-
+
chown -R tomcat:apache ${D}/etc/open-xchange/groupware/sslcerts
find ${D}/etc/open-xchange/groupware/sslcerts -name '*.pem' -exec chmod 440 {} \;
fi
@@ -446,7 +445,7 @@ pkg_postinst() {
einfo "to setup the initial open-xchange environment."
einfo
-
+
ewarn "If you upgrade from a prior version you should execute the following command."
ewarn "psql -U ${OX_DBUSER} ${OX_DBNAME} < ${ROOT}usr/share/open-xchange/ox_reminder.sql"