summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.6-r2.ebuild')
-rw-r--r--www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.6-r2.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.6-r2.ebuild b/www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.6-r2.ebuild
deleted file mode 100644
index 58df82d33a65..000000000000
--- a/www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.6-r2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox-bin/mozilla-firefox-bin-1.0.6-r2.ebuild,v 1.2 2005/08/11 20:21:37 flameeyes Exp $
-
-inherit eutils mozilla-launcher multilib
-
-DESCRIPTION="Firefox Web Browser"
-SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/linux-i686/en-US/firefox-${PV}.tar.gz"
-HOMEPAGE="http://www.mozilla.org/projects/firefox"
-RESTRICT="nostrip"
-
-KEYWORDS="-* amd64 x86"
-SLOT="0"
-LICENSE="MPL-1.1 NPL-1.1"
-IUSE=""
-
-DEPEND="virtual/libc"
-RDEPEND="virtual/x11
- x86? (
- >=sys-libs/lib-compat-1.0-r2
- >=x11-libs/gtk+-2.2
- )
- amd64? (
- >=app-emulation/emul-linux-x86-baselibs-1.0
- >=app-emulation/emul-linux-x86-gtklibs-1.0
- )
- >=www-client/mozilla-launcher-1.41"
-
-S=${WORKDIR}/firefox
-
-pkg_setup() {
- # This is a binary x86 package => ABI=x86
- # Please keep this in future versions
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
- has_multilib_profile && ABI="x86"
-}
-
-src_install() {
- declare MOZILLA_FIVE_HOME=/opt/firefox
-
- # Install firefox in /opt
- dodir ${MOZILLA_FIVE_HOME%/*}
- mv ${S} ${D}${MOZILLA_FIVE_HOME}
-
- # Create /usr/bin/firefox-bin
- install_mozilla_launcher_stub firefox-bin ${MOZILLA_FIVE_HOME}
-
- # Install icon and .desktop for menu entry
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/icon/mozillafirefox-bin-icon.png
- insinto /usr/share/applications
- doins ${FILESDIR}/icon/mozillafirefox-bin.desktop
-}
-
-pkg_preinst() {
- declare MOZILLA_FIVE_HOME=/opt/firefox
-
- # Remove entire installed instance to prevent all kinds of
- # problems... see bug 44772 for example
- rm -rf ${ROOT}${MOZILLA_FIVE_HOME}
-}
-
-pkg_postinst() {
- if use amd64; then
- echo
- einfo "NB: You just installed a 32-bit firefox"
- fi
-
- update_mozilla_launcher_symlinks
-}
-
-pkg_postrm() {
- update_mozilla_launcher_symlinks
-}