summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/openbox/openbox-3.3.1.ebuild')
-rw-r--r--x11-wm/openbox/openbox-3.3.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/x11-wm/openbox/openbox-3.3.1.ebuild b/x11-wm/openbox/openbox-3.3.1.ebuild
deleted file mode 100644
index 2ca65abaddf0..000000000000
--- a/x11-wm/openbox/openbox-3.3.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.3.1.ebuild,v 1.10 2007/05/02 03:35:59 omp Exp $
-
-inherit eutils
-
-DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager."
-HOMEPAGE="http://icculus.org/openbox/"
-SRC_URI="http://icculus.org/${PN}/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="alpha amd64 hppa ppc ~ppc64 sparc x86 ~x86-fbsd"
-IUSE="nls pango startup-notification xinerama"
-
-RDEPEND=">=dev-libs/glib-2
- >=dev-libs/libxml2-2.0
- >=media-libs/fontconfig-2
- virtual/xft
- x11-libs/libXrandr
- x11-libs/libXt
- pango? ( x11-libs/pango )
- startup-notification? ( x11-libs/startup-notification )
- xinerama? ( x11-libs/libXinerama )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto
- xinerama? ( x11-proto/xineramaproto )"
-
-src_compile() {
- econf \
- $(use_enable nls) \
- $(use_enable pango) \
- $(use_enable startup-notification) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- dodir /etc/X11/Sessions
- echo "/usr/bin/openbox" > "${D}/etc/X11/Sessions/${PN}"
- fperms a+x /etc/X11/Sessions/${PN}
-
- insinto /usr/share/xsessions
- doins "${FILESDIR}/${PN}.desktop"
-
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ABOUT-NLS AUTHORS CHANGELOG COMPLIANCE README
-}