aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2018-03-18 11:24:16 -0700
committerSteve Arnold <nerdboy@gentoo.org>2018-03-18 11:24:16 -0700
commit5b287eb326ec12ae6c7dd33c2c541738132b1a69 (patch)
treeb330e7f57ecbabbbc592fd9ba0af593497481c61
parentwww-client/firefox: attempts to corral firefox wonkiness (diff)
downloadarm-5b287eb326ec12ae6c7dd33c2c541738132b1a69.tar.gz
arm-5b287eb326ec12ae6c7dd33c2c541738132b1a69.tar.bz2
arm-5b287eb326ec12ae6c7dd33c2c541738132b1a69.zip
sys-power/cpufrequtils: needed an init script update
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
-rw-r--r--sys-power/cpufrequtils/cpufrequtils-008-r4.ebuild5
-rw-r--r--sys-power/cpufrequtils/files/cpufrequtils-init.d-00818
2 files changed, 20 insertions, 3 deletions
diff --git a/sys-power/cpufrequtils/cpufrequtils-008-r4.ebuild b/sys-power/cpufrequtils/cpufrequtils-008-r4.ebuild
index 42fa30e..a795f3f 100644
--- a/sys-power/cpufrequtils/cpufrequtils-008-r4.ebuild
+++ b/sys-power/cpufrequtils/cpufrequtils-008-r4.ebuild
@@ -1,6 +1,5 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufrequtils/Attic/cpufrequtils-008-r4.ebuild,v 1.9 2015/02/03 14:51:49 pacho dead $
EAPI=4
@@ -59,6 +58,6 @@ src_install() {
doexe "${FILESDIR}/cpufrequtils-change.sh"
systemd_dounit "${FILESDIR}/cpufrequtils.service"
- newinitd "${FILESDIR}"/${PN}-init.d-007 ${PN}
+ newinitd "${FILESDIR}"/${PN}-init.d-008 ${PN}
newconfd "${FILESDIR}"/${PN}-conf.d-006 ${PN}
}
diff --git a/sys-power/cpufrequtils/files/cpufrequtils-init.d-008 b/sys-power/cpufrequtils/files/cpufrequtils-init.d-008
new file mode 100644
index 0000000..5d48361
--- /dev/null
+++ b/sys-power/cpufrequtils/files/cpufrequtils-init.d-008
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufrequtils/files/cpufrequtils-init.d-007,v 1.2 2013/05/06 11:09:09 lxnay Exp $
+
+change() {
+ ebegin "Running cpufreq-set ${*}"
+ /usr/libexec/cpufrequtils-change.sh "${@}" > /dev/null
+ eend $?
+}
+
+start() {
+ change ${START_OPTS} -- ${SYSFS_EXTRA}
+}
+
+stop() {
+ change "${STOP_OPTS}"
+}