aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2014-05-27 10:08:41 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2014-05-27 10:08:41 -0700
commit91417ed174e52c2f53f0130478dde5ea6609acd9 (patch)
treee8d0f1a059b2351932649e7a3ab7d9d0b731e01e /sci-libs
parentnew git ebuild for latest upstream libgrate (diff)
downloadarm-91417ed174e52c2f53f0130478dde5ea6609acd9.tar.gz
arm-91417ed174e52c2f53f0130478dde5ea6609acd9.tar.bz2
arm-91417ed174e52c2f53f0130478dde5ea6609acd9.zip
add neon flag support
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/Manifest2
-rw-r--r--sci-libs/fftw/fftw-3.3.4.ebuild188
2 files changed, 190 insertions, 0 deletions
diff --git a/sci-libs/fftw/Manifest b/sci-libs/fftw/Manifest
new file mode 100644
index 0000000..a542e8a
--- /dev/null
+++ b/sci-libs/fftw/Manifest
@@ -0,0 +1,2 @@
+DIST fftw-3.3.4.tar.gz 3940427 SHA256 8f0cde90929bc05587c3368d2f15cd0530a60b8a9912a8e2979a72dbe5af0982 SHA512 1ee2c7bec3657f6846e63c6dfa71410563830d2b951966bf0123bd8f4f2f5d6b50f13b76d9a7b0eae70e44856f829ca6ceb3d080bb01649d1572c9f3f68e8eb1 WHIRLPOOL 2a5733f5537ff55a1830994431f1750dd790a4df3e8b3d1e9018c1afba2c5172f4e456eaee1c3427a2b170d23b6928da462e067a6f4e94792cfc7ff1cbc38938
+EBUILD fftw-3.3.4.ebuild 5267 SHA256 e4c7ded277fae633b0c7159a15789afd7c9a16f39b98315d44f4ba01fb396dee SHA512 5914718fe5a98cc06c7e6b9b78bc2d8b1b7ee23984556d37064581a0baa2f5153733ea3553ed2de227d3f50093b11b5fb2edb814e05f56fd07e363f68ffaed85 WHIRLPOOL a4541c166c1ac19902c59ba6133508bfd4a86c11ae249d89aa2ebd03f3b22fdcb9774cadbc1ea1d929e9cb7d97384fc8793b106cca2192b82389ac428e3c69af
diff --git a/sci-libs/fftw/fftw-3.3.4.ebuild b/sci-libs/fftw/fftw-3.3.4.ebuild
new file mode 100644
index 0000000..1739437
--- /dev/null
+++ b/sci-libs/fftw/fftw-3.3.4.ebuild
@@ -0,0 +1,188 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.4.ebuild,v 1.2 2014/05/24 22:14:53 mgorny Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit autotools-multilib eutils flag-o-matic fortran-2 multibuild toolchain-funcs versionator
+
+DESCRIPTION="Fast C library for the Discrete Fourier Transform"
+HOMEPAGE="http://www.fftw.org/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/FFTW/fftw3.git"
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ SRC_URI="http://www.fftw.org/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+fi
+
+LICENSE="GPL-2"
+SLOT="3.0/3"
+IUSE="altivec avx doc fma fortran mpi neon openmp quad sse sse2 static-libs test threads zbus"
+
+RDEPEND="
+ mpi? ( virtual/mpi )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r2
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ test? ( dev-lang/perl )"
+
+#can go once mpi is multlib
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/fftw3-mpi.h
+ /usr/include/fftw3l-mpi.f03
+ /usr/include/fftw3-mpi.f03
+ /usr/include/fftw3q.f03
+)
+
+pkg_setup() {
+ # XXX: this looks like it should be used with BUILD_TYPE!=binary
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ FORTRAN_NEED_OPENMP=1
+ fi
+
+ fortran-2_pkg_setup
+
+ MULTIBUILD_VARIANTS=( single double longdouble )
+ if use quad; then
+ if [[ $(tc-getCC) == *gcc ]] && ! version_is_at_least 4.6 $(gcc-version); then
+ ewarn "quad precision only available for gcc >= 4.6"
+ die "need quad precision capable gcc"
+ fi
+ MULTIBUILD_VARIANTS+=( quad )
+ fi
+}
+
+src_prepare() {
+ # fix info file for category directory
+ [[ ${PV} = *9999 ]] || sed -i \
+ -e 's/Texinfo documentation system/Libraries/' \
+ doc/fftw3."info" || die "failed to fix info file"
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local x
+
+ # filter -Os according to docs
+ replace-flags -Os -O2
+
+ # add neon flag for arm/neon
+ use neon && append-cflags -mfpu=neon
+
+ my_configure() {
+ #a bit hacky improve after #483758 is solved
+ local x=${BUILD_DIR%-*}
+ x=${x##*-}
+ # there is no abi_x86_32 port of virtual/mpi right now
+ local enable_mpi=$(use_enable mpi)
+ multilib_is_native_abi || enable_mpi="--disable-mpi"
+
+ #jlec reported USE=quad on abi_x86_32 has too less registers
+ #stub Makefiles
+ if use amd64 && ! multilib_is_native_abi && [[ $x = quad ]]; then
+ mkdir -p "${BUILD_DIR}/tests" || die
+ echo "all: ;" > "${BUILD_DIR}/Makefile" || die
+ echo "install: ;" >> "${BUILD_DIR}/Makefile" || die
+ echo "smallcheck: ;" > "${BUILD_DIR}/tests/Makefile" || die
+ return 0
+ fi
+
+ local myeconfargs=(
+ $(use_enable fma)
+ $(use_enable fortran)
+ $(use_enable zbus mips-zbus-timer)
+ $(use_enable threads)
+ $(use_enable openmp)
+ )
+ if [[ $x == single ]]; then
+ #altivec, sse, single-paired only work for single
+ myeconfargs+=(
+ --enable-single
+ $(use_enable altivec)
+ $(use_enable avx)
+ $(use_enable sse)
+ ${enable_mpi}
+ $(use_enable neon)
+ )
+ elif [[ $x == double ]]; then
+ myeconfargs+=(
+ $(use_enable avx)
+ $(use_enable sse2)
+ ${enable_mpi}
+ )
+ elif [[ $x == longdouble ]]; then
+ myeconfargs+=(
+ --enable-long-double
+ ${enable_mpi}
+ )
+ elif [[ $x == quad ]]; then
+ #quad does not support mpi
+ myeconfargs+=( --enable-quad-precision )
+ else
+ die "${x} precision not implemented in this ebuild"
+ fi
+
+ autotools-utils_src_configure
+ }
+
+ multibuild_foreach_variant multilib_parallel_foreach_abi my_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant autotools-multilib_src_compile
+}
+
+src_test () {
+ # We want this to be a reasonably quick test, but that is still hard...
+ ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
+ # Do not increase the number of threads, it will not help your performance
+ #local testbase="perl check.pl --nthreads=1 --estimate"
+ # ${testbase} -${p}d || die "Failure: $n"
+ multibuild_foreach_variant autotools-multilib_src_compile -C tests smallcheck
+}
+
+src_install () {
+ local u x
+ DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
+ HTML_DOCS=( doc/html/ )
+
+ #copied from autotools-multilib_secure_install
+ my_abi_src_install() {
+ autotools-utils_src_install
+ #https://github.com/FFTW/fftw3/pull/6
+ # f03 are installed unconditionally, not a big problem as the quad
+ # header is the only one to be wrapped.
+ [[ ${BUILD_DIR} = *-quad* ]] || rm -f "${ED}/usr/include/fftw3q.f03"
+ if [[ ${#MULTIBUILD_VARIANTS[@]} -gt 1 ]]; then
+ multilib_prepare_wrappers
+ multilib_check_headers
+ fi
+ }
+ multibuild_foreach_variant multilib_foreach_abi my_abi_src_install
+ multilib_install_wrappers
+
+ if use doc; then
+ dodoc doc/*.pdf
+ insinto /usr/share/doc/${PF}/faq
+ doins -r doc/FAQ/fftw-faq.html/*
+ else
+ rm -r "${ED}"/usr/share/doc/${PF}/html
+ fi
+
+ for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
+ for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
+ sed -e "s|-lfftw3[flq]\?|&_$u &|" "$x" > "${x%.pc}_$u.pc" || die
+ done
+ done
+}