aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2014-05-27 10:10:01 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2014-05-27 10:10:01 -0700
commit7f606ec622a37ed46a64f6d4bf1749b105f769e5 (patch)
tree2c2d9d40eabf1e5b1d19be2bdc5959e358c1de5b /virtual/opengl
parentadd neon flag support (diff)
downloadarm-7f606ec622a37ed46a64f6d4bf1749b105f769e5.tar.gz
arm-7f606ec622a37ed46a64f6d4bf1749b105f769e5.tar.bz2
arm-7f606ec622a37ed46a64f6d4bf1749b105f769e5.zip
add grate/tegra to opengl virtual
Diffstat (limited to 'virtual/opengl')
-rw-r--r--virtual/opengl/Manifest2
-rw-r--r--virtual/opengl/metadata.xml8
-rw-r--r--virtual/opengl/opengl-7.0-r1.ebuild25
3 files changed, 35 insertions, 0 deletions
diff --git a/virtual/opengl/Manifest b/virtual/opengl/Manifest
new file mode 100644
index 0000000..991c63b
--- /dev/null
+++ b/virtual/opengl/Manifest
@@ -0,0 +1,2 @@
+EBUILD opengl-7.0-r1.ebuild 591 SHA256 8507e266b6bf32b40d7af8faca2f13ac0a19ae40daf32332fa2092345c3b3715 SHA512 5460897cbec9e879a902b6a5ac78b18884a672adae98fe12598e6846e22b84cc365a5652ab45a61d0f64bf11ce49395c03a8b2bb12da1a04458b03641dad961a WHIRLPOOL a44ff58804b1c5a324da556eb940fbc569a24ffe2b35f7323b66d5fffe5e7c3a01d19f482e1b9af436424b471b0d14fab0f587c7456d607320e71c212ce7344c
+MISC metadata.xml 231 SHA256 677074bb8317b65d8ecf00cd7a2a3df38f77685b098c5e4ae2bac14ab9475238 SHA512 ea9d489077aac753fb9feaa9932e1feb26afd353802b82849ba9dc26e98ef579d5e6638331bf75c3f01b55654525e5863a46db861975ececa07c9607803e023a WHIRLPOOL 6122d5349d04b26debc01f948f2025cec08175a63b3dd15cc2248202feaa84d1d99b352940d77deaf04c6cb240324bfe93b202e5710a0256909d7d2222481a51
diff --git a/virtual/opengl/metadata.xml b/virtual/opengl/metadata.xml
new file mode 100644
index 0000000..ded6c86
--- /dev/null
+++ b/virtual/opengl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+<use>
+ <flag name="tegra">enforces tegra lib dependencies</flag>
+</use>
+</pkgmetadata>
diff --git a/virtual/opengl/opengl-7.0-r1.ebuild b/virtual/opengl/opengl-7.0-r1.ebuild
new file mode 100644
index 0000000..ee7c42f
--- /dev/null
+++ b/virtual/opengl/opengl-7.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for OpenGL implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="tegra"
+
+RDEPEND="
+ || (
+ ( media-libs/mesa[${MULTILIB_USEDEP}]
+ tegra? ( media-libs/grate )
+ )
+ media-libs/opengl-apple
+ )"
+DEPEND=""