aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2017-03-25 00:47:28 -0700
committerSteve Arnold <nerdboy@gentoo.org>2017-03-25 00:47:28 -0700
commit5dc0eb811b2cd0232111e3ce769e400c406589f5 (patch)
tree3d0f838db31bf56e942e30ea55299ecbcb6c6bb1 /x11-drivers
parentlibdrm-armada: new ebuild, Armada/etnaviv libdrm buffer interface (diff)
downloadarm-5dc0eb811b2cd0232111e3ce769e400c406589f5.tar.gz
arm-5dc0eb811b2cd0232111e3ce769e400c406589f5.tar.bz2
arm-5dc0eb811b2cd0232111e3ce769e400c406589f5.zip
xf86-video-armada: new ebuild, xf86-video-armada video driver
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-armada/xf86-video-armada-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-armada/xf86-video-armada-9999.ebuild b/x11-drivers/xf86-video-armada/xf86-video-armada-9999.ebuild
new file mode 100644
index 0000000..594b819
--- /dev/null
+++ b/x11-drivers/xf86-video-armada/xf86-video-armada-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+XORG_BASE_INDIVIDUAL_URI=""
+EGIT_REPO_URI="https://github.com/VCTLabs/xf86-video-armada"
+XORG_DRI="always"
+
+inherit xorg-2
+
+DESCRIPTION="Xorg graphics driver for KMS based systems with pluggable GPU backend"
+KEYWORDS="~arm"
+
+RDEPEND=">=x11-base/xorg-server-1.17"
+
+DEPEND="${RDEPEND}
+ x11-libs/libdrm-armada
+ x11-libs/libetnaviv
+"
+
+XORG_CONFIGURE_OPTIONS=(
+ --disable-vivante
+ --disable-etnaviv )