aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcnd <cynede@gentoo.org>2019-10-19 10:31:39 +0400
committerGitHub <noreply@github.com>2019-10-19 10:31:39 +0400
commit6d9d69b922bb2672cf28fbece2353e74a16b7c40 (patch)
treeaf5285d69e29397deabf29255e19b4c42d07f565 /app-shells
parentMerge pull request #442 from hoehnp/fix_repo_issues (diff)
parentSetting permissions byte for pwsh correctly (diff)
downloaddotnet-6d9d69b922bb2672cf28fbece2353e74a16b7c40.tar.gz
dotnet-6d9d69b922bb2672cf28fbece2353e74a16b7c40.tar.bz2
dotnet-6d9d69b922bb2672cf28fbece2353e74a16b7c40.zip
Merge pull request #441 from dargonforce/powershell
pwsh-bin ebuild
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh-bin/Manifest1
-rw-r--r--app-shells/pwsh-bin/metadata.xml8
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-6.2.3.ebuild29
3 files changed, 38 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
new file mode 100644
index 0000000..bb25990
--- /dev/null
+++ b/app-shells/pwsh-bin/Manifest
@@ -0,0 +1 @@
+DIST powershell-6.2.3-linux-x64.tar.gz 57418788 SHA256 48d7d33bd63f10d06ecd68f2efc9c07b5eca1ab1e492d08b586918c09a85105e SHA512 a8b80f8381ae75d55dc306ae1cf7488f82020ac5ac9baaade5d5878fda584b1f300dd0a868b3cada2a8d3cda14e37c0a218792bfae3906df09558db9045f3834 WHIRLPOOL 5a063dc0ce3c20761c0a8319999115253d380419a71c453a018039dd4e3a4c75d1dec38aaf2fae7c2b0499eba32187a011ff18cf8e194923e5c3208fbee44e14
diff --git a/app-shells/pwsh-bin/metadata.xml b/app-shells/pwsh-bin/metadata.xml
new file mode 100644
index 0000000..60328c2
--- /dev/null
+++ b/app-shells/pwsh-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <description>Gentoo Dotnet Project</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/pwsh-bin/pwsh-bin-6.2.3.ebuild b/app-shells/pwsh-bin/pwsh-bin-6.2.3.ebuild
new file mode 100644
index 0000000..48cbf1d
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-6.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="PowerShell - binary precompiled for glibc"
+HOMEPAGE="https://powershell.org/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://github.com/PowerShell/PowerShell/releases/download/v${PV}/powershell-${PV}-linux-x64.tar.gz -> powershell-${PV}-linux-x64.tar.gz )
+"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+"
+
+S=${WORKDIR}
+
+src_install() {
+ local dest="opt/pwsh"
+ dodir "${dest}"
+ local ddest="${D}/${dest}"
+ cp -a "${S}"/* "${ddest}/" || die
+ fperms 0755 "/${dest}/pwsh"
+ dosym "/${dest}/pwsh" "/usr/bin/pwsh"
+}