aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/webkitgtk-sharp/webkitgtk-sharp-2.0.0.ebuild')
-rw-r--r--dev-dotnet/webkitgtk-sharp/webkitgtk-sharp-2.0.0.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-dotnet/webkitgtk-sharp/webkitgtk-sharp-2.0.0.ebuild b/dev-dotnet/webkitgtk-sharp/webkitgtk-sharp-2.0.0.ebuild
index a2be5a5..e9159db 100644
--- a/dev-dotnet/webkitgtk-sharp/webkitgtk-sharp-2.0.0.ebuild
+++ b/dev-dotnet/webkitgtk-sharp/webkitgtk-sharp-2.0.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit mono-env autotools eutils
+inherit autotools mono-env
DESCRIPTION="C# bindings for WebKitGTK+ 3.0 using GObject Introspection"
HOMEPAGE="https://github.com/stsundermann/webkitgtk-sharp"
@@ -12,19 +12,23 @@ SRC_URI="https://github.com/stsundermann/${PN}/archive/${PV}.tar.gz -> ${P}.tar.
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="
>=dev-lang/mono-2.11
>=dev-dotnet/gtk-sharp-2.99.2:3
net-libs/webkit-gtk:3=
dev-dotnet/soup-sharp"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fadd308-libdir.patch"
+ "${FILESDIR}/${P}-aaad3bf-mcs.patch"
+)
src_prepare() {
- epatch "$FILESDIR/${P}-fadd308-libdir.patch"
- epatch "$FILESDIR/${P}-aaad3bf-mcs.patch"
+ default
+
eautoreconf -I . -I m4
}