aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Langenmaier <stefan.langenmaier@gmail.com>2015-11-10 17:49:31 -0500
committerStefan Langenmaier <stefan.langenmaier@gmail.com>2015-11-10 17:49:31 -0500
commit2f0d451b310d0b1f5a23de72ba5bd441370f8c55 (patch)
treec54b7930c0621f2506838b4f7d5527b2431209ea
parentdev-util/eclipse-sdk-bin: Do not unbundle ICU by default (issue #5) (diff)
downloadeclipse-2f0d451b310d0b1f5a23de72ba5bd441370f8c55.tar.gz
eclipse-2f0d451b310d0b1f5a23de72ba5bd441370f8c55.tar.bz2
eclipse-2f0d451b310d0b1f5a23de72ba5bd441370f8c55.zip
updated to the latest minor release
-rw-r--r--dev-util/eclipse-sdk-bin/Manifest2
-rw-r--r--dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.5.1.ebuild108
-rw-r--r--dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.1-eclipse-bin43
-rw-r--r--dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.1-eclipserc-bin20
4 files changed, 173 insertions, 0 deletions
diff --git a/dev-util/eclipse-sdk-bin/Manifest b/dev-util/eclipse-sdk-bin/Manifest
index 6564fa2..02847c5 100644
--- a/dev-util/eclipse-sdk-bin/Manifest
+++ b/dev-util/eclipse-sdk-bin/Manifest
@@ -1,2 +1,4 @@
+DIST eclipse-java-mars-1-linux-gtk-4.5.1.tar.gz 173132152 SHA256 4e983571957bfe79e810164ba42d03d9969836c9fff17f6021b9f7bb476966f9 SHA512 0721b15b65abbe8dbf84aa0c57241d79b65655854bea9c3d6f1269ef1aef1f6feaad961b73637cb3dad8cc6bf466839e1900b810140511c24d6e187810e8becc WHIRLPOOL 39980833f16da604a777020c274eb8333697732544043b0bce2338840811b684c74d6d640e600d1c0a193e20d90b7e6ffdfdacaaf356ccba56e518603fdcceef
+DIST eclipse-java-mars-1-linux-gtk-x86_64-4.5.1.tar.gz 173275940 SHA256 04dd54df5d047fba63677b56f90ee8fd880cd206c7075ea9332095efa7f25663 SHA512 3ebeaab354116aba06d08ccb2df81bfb148ddc3c145b53ac0c5f9fffe15e45e5ede1bac37acc9381b239d19dd766bb86c5e1122e02628e47ca1181a9178cb4ef WHIRLPOOL a14472f5a497ebb955a3897d71d56e2fc768b074b529d964267a998acd01bf8c32ec0294318e3e716362c2ad542c1216f75b3f35af1369537d2d7716e3a4a57b
DIST eclipse-java-mars-R-linux-gtk-4.5.0.tar.gz 169974282 SHA256 43089aa4738d05e92fd24cf320336e8ab1cfd2e66ce07de9955a40bf7a08de87 SHA512 de17412b82c6150268142e99858f26641b465c1c296a1a13d413a47226dc9a01db26bd07985c926b5fe80e0225ff7b3e0ef35137fce31e0bb261ae5cc96cc888 WHIRLPOOL 9ccbcc5c36711531a2f93daf8bab92892f589822cee09f5751fcf0ab7a1fe3e183100cfe4a9e71ecefe3a04a1b2bae2843162b27250a052ed4846f343fa0bbb1
DIST eclipse-java-mars-R-linux-gtk-x86_64-4.5.0.tar.gz 170118332 SHA256 2eeea5e563001f6812bad97e159befe4152bf8ef49124c98e635fd68104a1727 SHA512 9997a23d29e95c91177cd7460291caab46f04ca9b4af52b724c0d61577a16fa69b0aa4cdd01322aba21a05da24380d3f9395f799be4af8fc41c373353573a517 WHIRLPOOL 4d468c1959e2f9dd5b5fd661e60b56c55aa6d5fbc4b090d749237dfb56146213ab51716c8f645a288357b9302975d84a9aa502f94b07d78a7da31d84dead48db
diff --git a/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.5.1.ebuild b/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.5.1.ebuild
new file mode 100644
index 0000000..912f0d5
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/eclipse-sdk-bin-4.5.1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils versionator java-utils-2
+
+SR="1"
+RNAME="mars"
+
+SRC_BASE="http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/${RNAME}/${SR}/eclipse-java-${RNAME}-${SR}-linux-gtk"
+
+DESCRIPTION="Eclipse SDK"
+HOMEPAGE="http://www.eclipse.org"
+SRC_URI="
+ amd64? ( ${SRC_BASE}-x86_64.tar.gz&r=1 -> eclipse-java-${RNAME}-${SR}-linux-gtk-x86_64-${PV}.tar.gz )
+ x86? ( ${SRC_BASE}.tar.gz&r=1 -> eclipse-java-${RNAME}-${SR}-linux-gtk-${PV}.tar.gz )
+ "
+
+LICENSE="EPL-1.0"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE="system-icu"
+
+CDEPEND="
+ >=dev-java/commons-httpclient-3.1:3
+ system-icu? ( >=dev-java/icu4j-54.1.1:52 )
+ >=dev-java/javax-inject-1:0
+ >=dev-java/jsr250-1.2:0
+ >=dev-java/xml-commons-resolver-1.2:0
+ "
+DEPEND="${CDEPEND}"
+RDEPEND=">=virtual/jdk-1.6
+ x11-libs/gtk+:2
+ ${CDEPEND}"
+
+S="${WORKDIR}"/eclipse
+
+_unbundle_single() {
+ local mode="${1}" destination_jar="${2}" package="${3}" package_jar="${4}"
+ local abs_destination_jar="${PWD}/${destination_jar}"
+ local backup_dir="${T}"/${destination_jar##*/}.dir
+
+ if [[ "${mode}" = delete ]]; then
+ # Backup META-INF/MANIFEST.MF with checksums
+ # Then delete .jar file
+ mkdir -p "${backup_dir}"/META-INF
+ unzip -p "${destination_jar}" META-INF/MANIFEST.MF \
+ | sed -e '/^Name:/d' -e '/^SHA1-Digest:/d' -e '/^\s*$/d' \
+ > "${backup_dir}"/META-INF/MANIFEST.MF || die
+ rm "${destination_jar}" || die
+ elif [[ "${mode}" = wire ]]; then
+ einfo "Replacing bundled ${destination_jar}..."
+ # Create new .jar based on system-wide build
+ # In the process, apply META-INF/MANIFEST.MF backup
+ java-pkg_jar-from "${package}" "${package_jar}" "${destination_jar}"
+ local source_jar="$(readlink -f "${destination_jar}")"
+ rm "${destination_jar}" || die
+
+ cp "${source_jar}" "${destination_jar}" || die
+ ( cd "${backup_dir}" \
+ && [[ -f "${abs_destination_jar}" ]] \
+ && zip "${abs_destination_jar}" META-INF/MANIFEST.MF >/dev/null
+ ) || die
+ fi
+}
+
+_unbundle_known() {
+ local mode="${1}"
+
+ # https://wiki.gentoo.org/wiki/Eclipse/Building_From_Source
+ use system-icu && _unbundle_single "${mode}" plugins/com.ibm.icu_54.1.1.v201501272100.jar icu4j-52 icu4j.jar
+ _unbundle_single "${mode}" plugins/javax.annotation_1.2.0.v201401042248.jar jsr250 jsr250.jar
+ _unbundle_single "${mode}" plugins/javax.inject_1.0.0.v20091030.jar javax-inject javax-inject.jar
+ _unbundle_single "${mode}" plugins/org.apache.commons.httpclient_3.1.0.v201012070820.jar commons-httpclient-3 commons-httpclient.jar
+ _unbundle_single "${mode}" plugins/org.apache.xml.resolver_1.2.0.v201005080400.jar xml-commons-resolver xml-commons-resolver.jar
+}
+
+src_prepare() {
+ _unbundle_known delete
+
+ ewarn 'Binary dependencies left to unbundle:'
+ ewarn "$(find -type f -name '*.jar' -not -wholename '*/org.eclipse*' | sort | sed 's,^\./,,')"
+
+ _unbundle_known wire
+
+ cp "${FILESDIR}"/${P}-eclipse-bin "${T}/eclipse-bin-${SLOT}" || die
+ cp "${FILESDIR}"/${P}-eclipserc-bin "${T}/eclipserc-bin-${SLOT}" || die
+ sed "s,%SLOT%,${SLOT},g" -i "${T}"/eclipse{,rc}-bin-${SLOT} || die
+}
+
+src_install() {
+ local dest=/opt/${PN}-${SLOT}
+
+ insinto ${dest}
+ doins -r features icon.xpm plugins artifacts.xml p2 eclipse.ini configuration dropins
+
+ exeinto ${dest}
+ doexe eclipse
+
+ dohtml -r readme/*
+
+ dobin "${T}"/eclipse-bin-${SLOT}
+ insinto /etc
+ doins "${T}"/eclipserc-bin-${SLOT}
+ make_desktop_entry "eclipse-bin-${SLOT}" "Eclipse ${RNAME^}/${PV} (bin)" "${dest}/icon.xpm"
+}
diff --git a/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.1-eclipse-bin b/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.1-eclipse-bin
new file mode 100644
index 0000000..87d5531
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.1-eclipse-bin
@@ -0,0 +1,43 @@
+#! /bin/bash
+#
+# Tiny startup wrapper for Eclipse
+#
+# Copyright (c) 2004, Karl Trygve Kalleberg <karltk@gentoo.org>
+# Copyright (c) 2007-2008, Jean-Noël Rivasseau <elvanor@gentoo.org>
+# Copyright (c) 2004-2008, Gentoo Foundation
+# Copyright (c) 2015, Sebastian Pipping <sping@gentoo.org>
+#
+# Licensed under the GNU General Public License, version 2
+#
+
+[[ -f "/etc/eclipserc-bin-%SLOT%" ]] && . "/etc/eclipserc-bin-%SLOT%"
+[[ -f "$HOME/gentoo/.eclipserc" ]] && . "$HOME/gentoo/.eclipserc"
+
+ECLIPSE_HOME=${ECLIPSE_HOME:="/opt/eclipse-sdk-bin-%SLOT%"}
+ECLIPSE_BIN="${ECLIPSE_HOME}/eclipse"
+
+if [[ ! -x "${ECLIPSE_BIN}" ]] ; then
+ echo "Failed to find executable '${ECLIPSE_BIN}'" > /dev/stderr
+ exit 1
+fi
+
+if [[ $(id -u) -eq 0 ]] ; then
+ echo "Do not run eclipse as root user! Exiting ..." > /dev/stderr
+ exit 1
+fi
+
+case "$(java-config -f)" in
+ *gcj*)
+ export JAVA_PKG_CLASSMAP="${ECLIPSE_HOME}/eclipse.gcjdb"
+ ;;
+esac
+
+[ -n "${ECLIPSE_XMS}" ] && VM_ARGS="${VM_ARGS} -Xms${ECLIPSE_XMS}"
+[ -n "${ECLIPSE_XMX}" ] && VM_ARGS="${VM_ARGS} -Xmx${ECLIPSE_XMX}"
+[ -n "${ECLIPSE_PERMSIZE}" ] && VM_ARGS="${VM_ARGS} -XX:PermSize=${ECLIPSE_PERMSIZE}"
+[ -n "${ECLIPSE_MAX_PERMSIZE}" ] && VM_ARGS="${VM_ARGS} -XX:MaxPermSize=${ECLIPSE_MAX_PERMSIZE}"
+
+# Fix for JRE 1.5.
+export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/lib
+
+exec "${ECLIPSE_BIN}" -vm $(java-config --java) "$@" "${ECLIPSE_USER_ARGS}" -vmargs ${VM_ARGS}
diff --git a/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.1-eclipserc-bin b/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.1-eclipserc-bin
new file mode 100644
index 0000000..c2c334e
--- /dev/null
+++ b/dev-util/eclipse-sdk-bin/files/eclipse-sdk-bin-4.5.1-eclipserc-bin
@@ -0,0 +1,20 @@
+# This file specifies some initial Eclipse settings, like memory allowed
+# These settings only affect Eclipse startup and overall configuration
+# Main Eclipse configuration should be done within Eclipse (with the GUI)
+
+# Following variables controls the minimal and maximum amounts of memory
+# allocated to Eclipse (respectively).
+# Increase those numbers if you get OutOfMemory errors.
+
+ECLIPSE_XMS=128m
+ECLIPSE_XMX=256m
+
+# Following variables controls the minimal and maximum amounts of memory
+# allocated to the permanent generation space.
+# This space contains data related to all classes.
+# Thus, if you use a lot of Eclipse plugins, it is recommended to uncomment
+# these variables and even increase it, if you have enough RAM.
+# Else you will get crashes related to OutOfMemory in PermGen exceptions.
+
+#ECLIPSE_PERMSIZE=64m
+#ECLIPSE_MAX_PERMSIZE=128m