aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-05-10 23:40:24 -0400
committerMike Gilbert <floppym@gentoo.org>2016-05-10 23:40:24 -0400
commitae51434f1480977c8f339b24ff5514ddf6dd3205 (patch)
tree57349c42cc2df853ac49981173da67ebe230fb98
parentebuild-test/eapi-definition: test that EAPI is defined according to PMS (diff)
downloadgen-b0rk-ae51434f1480977c8f339b24ff5514ddf6dd3205.tar.gz
gen-b0rk-ae51434f1480977c8f339b24ff5514ddf6dd3205.tar.bz2
gen-b0rk-ae51434f1480977c8f339b24ff5514ddf6dd3205.zip
ebuild-test/patches: test that PATCHES is an array
-rw-r--r--ebuild-test/patches/metadata.xml26
-rw-r--r--ebuild-test/patches/patches-0.ebuild14
2 files changed, 40 insertions, 0 deletions
diff --git a/ebuild-test/patches/metadata.xml b/ebuild-test/patches/metadata.xml
new file mode 100644
index 0000000..da7c4a8
--- /dev/null
+++ b/ebuild-test/patches/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for ???</longdescription>
+</pkgmetadata>
diff --git a/ebuild-test/patches/patches-0.ebuild b/ebuild-test/patches/patches-0.ebuild
new file mode 100644
index 0000000..78659cc
--- /dev/null
+++ b/ebuild-test/patches/patches-0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Test that PATCHES is an array"
+HOMEPAGE="http://example.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES="foo.patch"