aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ebuild-test/inherit-missing/inherit-missing-0.ebuild19
-rw-r--r--ebuild-test/inherit-missing/metadata.xml26
2 files changed, 45 insertions, 0 deletions
diff --git a/ebuild-test/inherit-missing/inherit-missing-0.ebuild b/ebuild-test/inherit-missing/inherit-missing-0.ebuild
new file mode 100644
index 0000000..10da580
--- /dev/null
+++ b/ebuild-test/inherit-missing/inherit-missing-0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Missing inherits"
+HOMEPAGE="http://example.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ # missing eutils
+ edos2unix foo
+ # missing flag-o-matic
+ strip-flags
+}
diff --git a/ebuild-test/inherit-missing/metadata.xml b/ebuild-test/inherit-missing/metadata.xml
new file mode 100644
index 0000000..da7c4a8
--- /dev/null
+++ b/ebuild-test/inherit-missing/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for ???</longdescription>
+</pkgmetadata>