aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-07-04 03:51:17 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-07-04 04:18:23 +0200
commite00a1f8a61dabd213e495825a678900d6ddbd5c3 (patch)
tree86dfc4ecd21d85f0d85a8cbd8b88adc961c0caf4 /app-admin
parentapp-admin/rbw: add upstream metadata (diff)
downloadguru-e00a1f8a61dabd213e495825a678900d6ddbd5c3.tar.gz
guru-e00a1f8a61dabd213e495825a678900d6ddbd5c3.tar.bz2
guru-e00a1f8a61dabd213e495825a678900d6ddbd5c3.zip
app-admin/rbw: sync live
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/rbw/rbw-9999.ebuild42
1 files changed, 31 insertions, 11 deletions
diff --git a/app-admin/rbw/rbw-9999.ebuild b/app-admin/rbw/rbw-9999.ebuild
index 9e9ca4d11..70fc347d0 100644
--- a/app-admin/rbw/rbw-9999.ebuild
+++ b/app-admin/rbw/rbw-9999.ebuild
@@ -1,25 +1,39 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cargo shell-completion
-DESCRIPTION="unofficial bitwarden cli"
+DESCRIPTION="Unofficial Bitwarden CLI"
HOMEPAGE="https://git.tozt.net/rbw"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.tozt.net/rbw"
else
- SRC_URI="https://git.tozt.net/rbw/snapshot/rbw-${PV}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris ${CRATES})"
+ SRC_URI="https://git.tozt.net/rbw/snapshot/${P}.tar.gz
+ ${CARGO_CRATE_URIS}"
KEYWORDS="~amd64"
fi
LICENSE="MIT"
+# Dependent crate licenses
+LICENSE+=" Apache-2.0 BSD Boost-1.0 ISC MIT Unicode-DFS-2016"
+# Manually added crate licenses
+LICENSE+=" openssl"
SLOT="0"
+# copypasta crate provides wayland clipboard support via dlopen calls against
+# libwayland-client.so
+RDEPEND="app-crypt/pinentry"
+BDEPEND=">=virtual/rust-1.74"
+
+QA_FLAGS_IGNORED="
+ usr/bin/rbw
+ usr/bin/rbw-agent
+"
+
src_unpack() {
if [[ ${PV} = *9999* ]]; then
git-r3_src_unpack
@@ -29,15 +43,21 @@ src_unpack() {
fi
}
+src_compile() {
+ # cc-rs picks up CFLAGS from the env
+ export CFLAGS
+ cargo_src_compile
+}
+
src_install() {
cargo_src_install
- rbw gen-completions bash > rbw.bash || die
- dobashcomp rbw.bash
-
- rbw gen-completions fish > rbw.fish || die
+ local comp DOCS="CHANGELOG.md README.md"
+ for comp in bash fish zsh; do
+ "$(cargo_target_dir)"/rbw gen-completions ${comp} > rbw.${comp} || die
+ done
+ newbashcomp rbw.bash rbw
dofishcomp rbw.fish
-
- rbw gen-completions zsh > _rbw || die
- dozshcomp _rbw
+ newzshcomp rbw.zsh _rbw
+ einstalldocs
}