aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2024-06-04 15:46:08 -0400
committerWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2024-06-04 15:46:08 -0400
commit8714381ef5750a50c5cb58c024a53a7353557e4e (patch)
tree19227f459cf63e085676de8d5c20d033d3911ae3 /app-backup
parentdev-python/b2sdk: bump to v2.3.0 (diff)
downloadguru-8714381ef5750a50c5cb58c024a53a7353557e4e.tar.gz
guru-8714381ef5750a50c5cb58c024a53a7353557e4e.tar.bz2
guru-8714381ef5750a50c5cb58c024a53a7353557e4e.zip
app-backup/b2: bump to 4.0.1
Signed-off-by: Wolfgang E. Sanyer <ezzieyguywuf@gmail.com>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/b2/Manifest1
-rw-r--r--app-backup/b2/b2-4.0.1.ebuild75
-rw-r--r--app-backup/b2/files/b2-4.0.1-nameclash.patch17
3 files changed, 93 insertions, 0 deletions
diff --git a/app-backup/b2/Manifest b/app-backup/b2/Manifest
index 92370c8f8..604ce7bb8 100644
--- a/app-backup/b2/Manifest
+++ b/app-backup/b2/Manifest
@@ -1,2 +1,3 @@
DIST b2-3.18.0.gh.tar.gz 189572 BLAKE2B 9516d98c7c493791f120c345480f16c8d615cbf425f692fa3fe6688c21ef7d26f14cdd7b44cfb22f2c13a5554166c046eb5fa1712a1e1994fa4e4181399eda84 SHA512 45c784e961b8b650d27e7fe642cacd194462b3c0864fdc1af52e41a70b435c36fbb803e80cfb2c88b8165ea95459a7e62b1995f26caf612110f8c77418cb6669
DIST b2-3.9.0.tar.gz 131326 BLAKE2B c357831b7c0b4ae6abc4fafb6e09690f8ffe833d2c58c05610ffdbf94ba276f5fa143dd1528f7e7424b6fa96857c8328be993e6ffc60b61c44037bd9ef0b0e96 SHA512 db2fab07e973d6d39db3931dd7f645ee3c9737f4de0ab29327490607d52aad4df2e9049782ef347ee44f80b76dbe91f495ce273285001d49195abe91d5b2cb5d
+DIST b2-4.0.1.gh.tar.gz 201737 BLAKE2B 74fb1dd52c8592816c2f2680469c2dd08910f8c25d4a923dd53258f63dd4c38ef77855e6845c41572b8fe52d33ee390a2fac6555016663c450feeb6ff89ed09e SHA512 02a14c2c78fecd1dda536539b5977d6ff45892db0355575209417d7f8471a45ace0d4766dd454c0ba0a65a1ae44e0c698cca38814b0bf36ca5e7a69efec9149a
diff --git a/app-backup/b2/b2-4.0.1.ebuild b/app-backup/b2/b2-4.0.1.ebuild
new file mode 100644
index 000000000..1f428d20f
--- /dev/null
+++ b/app-backup/b2/b2-4.0.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_10 python3_11 python3_12 )
+DISTUTILS_USE_PEP517="pdm-backend"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command-line tool for BackBlaze's B2 product"
+HOMEPAGE="https://github.com/Backblaze/B2_Command_Line_Tool"
+SRC_URI="https://github.com/Backblaze/B2_Command_Line_Tool/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/B2_Command_Line_Tool-${PV}"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${P}-nameclash.patch"
+)
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/argcomplete-2.1.2[${PYTHON_USEDEP}]
+ >=dev-python/arrow-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/b2sdk-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.19[${PYTHON_USEDEP}]
+ >=dev-python/phx-class-registry-4.0.6[${PYTHON_USEDEP}]
+ >=dev-python/rst2ansi-0.1.5[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.65.0[${PYTHON_USEDEP}]
+ ')
+"
+
+DEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/backoff-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/pexpect-4.8.0[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fixture 'worker_id' not found
+ "test/integration/test_b2_command_line.py"
+ "test/integration/test_help.py::test_help"
+ "test/integration/test_autocomplete.py"
+
+ # Timeout exceeded
+ # I think this is trying to access files outside of the sandbox
+ "test/unit/console_tool/test_install_autocomplete.py::test_install_autocomplete"
+
+ # TypeError: super(type, obj): obj must be an instance or subtype of type
+ # This test itself does not fail, but running it causes subsequent test to
+ # fail, which otherwise pass. Not really sure why (I assume this test is
+ # somehow polluting the test fixture?) but disabling causes the other tests
+ # to pass
+ "test/unit/_cli/test_autocomplete_cache.py"
+)
+python_test() {
+ epytest test
+}
+
+pkg_postinst() {
+ elog "The b2 executable has been renamed to backblaze2 in order to"
+ elog "avoid a name clash with b2 from boost-build"
+}
diff --git a/app-backup/b2/files/b2-4.0.1-nameclash.patch b/app-backup/b2/files/b2-4.0.1-nameclash.patch
new file mode 100644
index 000000000..463c4c387
--- /dev/null
+++ b/app-backup/b2/files/b2-4.0.1-nameclash.patch
@@ -0,0 +1,17 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index ff817d2..de26c16 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -65,9 +65,9 @@ full = [
+ Homepage = "https://github.com/Backblaze/B2_Command_Line_Tool"
+
+ [project.scripts]
+-b2 = "b2._internal.b2v4.__main__:main"
+-b2v3 = "b2._internal.b2v3.__main__:main"
+-b2v4 = "b2._internal.b2v4.__main__:main"
++backblaze2 = "b2._internal.b2v4.__main__:main"
++backblaze2v3 = "b2._internal.b2v3.__main__:main"
++backblaze2v4 = "b2._internal.b2v4.__main__:main"
+
+ [build-system]
+ requires = ["pdm-backend"]