aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2024-07-29 00:44:52 +0200
committerHenri Gasc <gasc@eurecom.fr>2024-07-29 00:45:01 +0200
commit6b1942c682a6dabb862bc00e2c13eeb440814b70 (patch)
treedaaf6d2d48964091320daaf74951b6732e91fee7 /app-editors
parentdev-libs/nativefiledialog-extended: add 1.2.0, drop 1.1.1-r1 (diff)
downloadguru-6b1942c682a6dabb862bc00e2c13eeb440814b70.tar.gz
guru-6b1942c682a6dabb862bc00e2c13eeb440814b70.tar.bz2
guru-6b1942c682a6dabb862bc00e2c13eeb440814b70.zip
app-editors/imhex: add 1.35.4, drop 1.35.3
Signed-off-by: Henri Gasc <gasc@eurecom.fr>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/imhex/Manifest4
-rw-r--r--app-editors/imhex/files/remove_Werror.patch22
-rw-r--r--app-editors/imhex/files/remove_dotnet.patch18
-rw-r--r--app-editors/imhex/imhex-1.35.4.ebuild (renamed from app-editors/imhex/imhex-1.35.3.ebuild)25
4 files changed, 26 insertions, 43 deletions
diff --git a/app-editors/imhex/Manifest b/app-editors/imhex/Manifest
index 2190fce9d..a12c04ad1 100644
--- a/app-editors/imhex/Manifest
+++ b/app-editors/imhex/Manifest
@@ -1,2 +1,2 @@
-DIST imhex-1.35.3.gh.tar.gz 33023289 BLAKE2B ebafcda5c873f87945f3d0135615932f545717988920086dd2f09e6ca1c62fda88f272f9ab6a2dae43db49083c9c0c5b6842c55d0c2d2ff667e3f49b84a01097 SHA512 711f98710b00da3ed826367a208678fa3231b02abc61b33d05034cefef3617f6641da78df88ba354a02a16c5d119ee8560fc66d95295214dcd0bdeaab9967c0c
-DIST imhex-patterns-1.35.3.gh.tar.gz 8114314 BLAKE2B 5f89d35c375d5dbe4d1e52ea5c41d86225aa6b5c76a960f430a5a32f94dd68e7ed8cc2fffdd7a3e7dec11f740ef3e226bd52ac3b1d461c0cc9af074a5b44f63d SHA512 6452bad26072dd178bdad2291e717749df361a098a5be7503c7c00e8e8486d2e465fd585d7fa82fe1927848efdcc681cf81e35255cb437231552816cf67ac568
+DIST imhex-1.35.4.gh.tar.gz 32738551 BLAKE2B 1e65a332a810af2884c6cf14dafa46cd2d09fc18891c48c7cb1007cab041b293e96db69db068b20d97fb5b51b16c3dbded38a679b65a8d7fd85ce705ae95d6d8 SHA512 a18215a76d949cd4bb7395c57965d1ca04fccad37142d130c17d3edbf8c383875a4f7e11ee3244aa4f08a5a512f19bd5e3e8ab3cdfb59603e7df142876c43318
+DIST imhex-patterns-1.35.4.gh.tar.gz 8212739 BLAKE2B ac79ed6bf919917323909b34f285d2bb48c2a1dadf9270ac09a41f627a07b726bd50751da00b6af1f7478c02c8e8de05d44f678840bf9aab377d96049e70d1fd SHA512 1af5818468eb0cf8d8078cd57d0659d93cf6d59380b3fc7e4cb07442ebc4f90e33e401516d1adafef65a696b458e1738984f92a5a5052a945a84422eda5a6bea
diff --git a/app-editors/imhex/files/remove_Werror.patch b/app-editors/imhex/files/remove_Werror.patch
index 891d61a48..cfd65aa75 100644
--- a/app-editors/imhex/files/remove_Werror.patch
+++ b/app-editors/imhex/files/remove_Werror.patch
@@ -1,21 +1,6 @@
---- a/cmake/build_helpers.cmake
-+++ b/cmake/build_helpers.cmake
-@@ -563,7 +563,7 @@ macro(setupCompilerFlags target)
- if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
- # Define strict compilation flags
- if (IMHEX_STRICT_WARNINGS)
-- set(IMHEX_COMMON_FLAGS "${IMHEX_COMMON_FLAGS} -Wall -Wextra -Wpedantic -Werror")
-+ set(IMHEX_COMMON_FLAGS "${IMHEX_COMMON_FLAGS} -Wall -Wextra -Wpedantic")
- endif()
-
- if (UNIX AND NOT APPLE AND CMAKE_CXX_COMPILER_ID MATCHES "GNU")
-@@ -871,4 +871,4 @@ function(precompileHeaders target includeFolder)
- PUBLIC
- "$<$<COMPILE_LANGUAGE:CXX>:${INCLUDES}>"
- )
--endfunction()
-\ No newline at end of file
-+endfunction()
+Remove -Werror where we can not control it using flags
+https://bugs.gentoo.org/921663
+Submodule lib/external/pattern_language contains modified content
--- a/lib/external/pattern_language/cli/CMakeLists.txt
+++ b/lib/external/pattern_language/cli/CMakeLists.txt
@@ -29,7 +29,7 @@ else()
@@ -38,4 +23,3 @@
if(CMAKE_CXX_COMPILER_ID MATCHES "GNU")
target_compile_options(libpl PRIVATE -Wno-stringop-overflow)
endif()
-
diff --git a/app-editors/imhex/files/remove_dotnet.patch b/app-editors/imhex/files/remove_dotnet.patch
index 5f241cf8d..fab61adf6 100644
--- a/app-editors/imhex/files/remove_dotnet.patch
+++ b/app-editors/imhex/files/remove_dotnet.patch
@@ -1,18 +1,20 @@
+Remove dotnet from the application
+https://bugs.gentoo.org/926761
--- a/plugins/script_loader/CMakeLists.txt
+++ b/plugins/script_loader/CMakeLists.txt
-@@ -2,7 +2,6 @@ cmake_minimum_required(VERSION 3.16)
+@@ -2,8 +2,6 @@ cmake_minimum_required(VERSION 3.16)
include(ImHexPlugin)
-find_package(CoreClrEmbed)
+-add_library(dotnet INTERFACE)
if (CoreClrEmbed_FOUND)
set(IMHEX_DOTNET_SCRIPT_SUPPORT ON)
-@@ -56,4 +55,4 @@ if (IMHEX_DOTNET_SCRIPT_SUPPORT)
-
- add_subdirectory(support/dotnet)
- add_dependencies(script_loader AssemblyLoader)
--endif()
+@@ -55,5 +53,4 @@ add_imhex_plugin(
+ c_api
+ fonts
+ ui
+- dotnet
+ )
\ No newline at end of file
-+endif()
-
diff --git a/app-editors/imhex/imhex-1.35.3.ebuild b/app-editors/imhex/imhex-1.35.4.ebuild
index 93f9baee0..427ad0bc6 100644
--- a/app-editors/imhex/imhex-1.35.3.ebuild
+++ b/app-editors/imhex/imhex-1.35.4.ebuild
@@ -3,7 +3,9 @@
EAPI=8
-inherit cmake llvm toolchain-funcs desktop
+LLVM_COMPAT=( {15..18} )
+
+inherit cmake llvm-r1 toolchain-funcs
DESCRIPTION="A hex editor for reverse engineers, programmers, and eyesight"
HOMEPAGE="https://github.com/WerWolv/ImHex"
@@ -36,10 +38,10 @@ DEPEND="
app-forensics/yara:=
>=dev-cpp/nlohmann_json-3.10.2
dev-libs/capstone:=
- dev-libs/nativefiledialog-extended:=
+ >=dev-libs/nativefiledialog-extended-1.2.0:=
>=dev-libs/libfmt-8.0.0:=
media-libs/freetype
- media-libs/glfw
+ >=media-libs/glfw-3.4[X]
media-libs/glm
media-libs/libglvnd
net-libs/mbedtls:=
@@ -63,6 +65,12 @@ pkg_pretend() {
fi
}
+src_unpack() {
+ default
+
+ mv "${WORKDIR}/ImHex-Patterns-ImHex-v${PV}" "${S}/ImHex-Patterns"
+}
+
src_configure() {
if use test; then
sed -ie "s/tests EXCLUDE_FROM_ALL/tests ALL/" "${S}/CMakeLists.txt"
@@ -95,14 +103,3 @@ src_configure() {
cmake_src_configure
}
-
-src_install() {
- cmake_src_install
-
- domenu "${S}/dist/${PN}.desktop"
-
- # Install patterns
- insinto /usr/share/imhex
- rm -rf "${S_PATTERNS}/tests"
- doins -r "${S_PATTERNS}"/*
-}