aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-08-09 04:55:55 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-08-09 04:55:55 +0500
commitc52fceda39490e55a8b4a60d21bbf1a32cc59e97 (patch)
tree0d78ac37c22d133fb827886e06755e47f375728e /app-vim/rainbow
parentnet-misc/gmid: add 2.1, drop 2.0.2 (diff)
downloadguru-c52fceda39490e55a8b4a60d21bbf1a32cc59e97.tar.gz
guru-c52fceda39490e55a8b4a60d21bbf1a32cc59e97.tar.bz2
guru-c52fceda39490e55a8b4a60d21bbf1a32cc59e97.zip
app-vim/rainbow: add 3.4.0_p20240727
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'app-vim/rainbow')
-rw-r--r--app-vim/rainbow/Manifest1
-rw-r--r--app-vim/rainbow/rainbow-3.4.0_p20240727.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/rainbow/Manifest b/app-vim/rainbow/Manifest
index b983da595..edad51858 100644
--- a/app-vim/rainbow/Manifest
+++ b/app-vim/rainbow/Manifest
@@ -1 +1,2 @@
DIST rainbow-3.4.0_p20211113.tar.gz 15077 BLAKE2B fefb0e71ef870a2e4cb698d43a677aafed116f28b529945dc5c473edb912a63bbf09cc124ee1fbb76fed9c3e9962c2fd2f473635a4381f40ee77d5a280c0a38b SHA512 4899404a58dc4eb7f42ecef428e922a55884d53750160aa04733e5313d1a2fb18832e30cfce8857d7e74cf3ab4bf88187ec86778330656127bde457219dc619b
+DIST rainbow-3.4.0_p20240727.tar.gz 15184 BLAKE2B e0edabec785ea4ded1b6e1bc155e1c9a84ffb4ea562fa6fb008e5be5097f67a2af21bc50a515b6a5d46bb637b50176198c8d46c81d7f3c2be7f63163adca0a20 SHA512 7c6c98d492aa6266b19b06903ad6980aa2e971a9f5867198635814c9c152e3d365dc38f169b392f9e34235fddbea01e75f3e9eaee67bad70af7e00f45f55a286
diff --git a/app-vim/rainbow/rainbow-3.4.0_p20240727.ebuild b/app-vim/rainbow/rainbow-3.4.0_p20240727.ebuild
new file mode 100644
index 000000000..3cfa3d636
--- /dev/null
+++ b/app-vim/rainbow/rainbow-3.4.0_p20240727.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1 vim-plugin
+
+COMMIT="76ca1a20aa42edb5c65c19029968aad4625790dc"
+DESCRIPTION="vim plugin: Rainbow Parentheses Improved"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=4176
+https://github.com/luochen1990/rainbow"
+SRC_URI="https://github.com/luochen1990/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="rainbow"
+
+src_install() {
+ vim-plugin_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ readme.gentoo_print_elog
+}