aboutsummaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMark Harmstone <mark@harmstone.com>2024-02-13 00:32:12 +0000
committerMark Harmstone <mark@harmstone.com>2024-02-13 00:34:28 +0000
commite3ebaec664ff8da0530a6d749b2626afe2177069 (patch)
treeb51ece91434a2976eec0b294f0ea058eb73c7556 /dev-db
parentapp-misc/ufetch: keyword 0.3 for ~arm64 (diff)
downloadguru-e3ebaec664ff8da0530a6d749b2626afe2177069.tar.gz
guru-e3ebaec664ff8da0530a6d749b2626afe2177069.tar.bz2
guru-e3ebaec664ff8da0530a6d749b2626afe2177069.zip
dev-db/tdscpp: new package, add 20240212
Signed-off-by: Mark Harmstone <mark@harmstone.com>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/tdscpp/Manifest1
-rw-r--r--dev-db/tdscpp/metadata.xml11
-rw-r--r--dev-db/tdscpp/tdscpp-20240212.ebuild35
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-db/tdscpp/Manifest b/dev-db/tdscpp/Manifest
new file mode 100644
index 000000000..4fa6624b3
--- /dev/null
+++ b/dev-db/tdscpp/Manifest
@@ -0,0 +1 @@
+DIST tdscpp-20240212.tar.gz 724415 BLAKE2B 669b2741deb4881b698db68ec5db09da79345caa59d6d2a41938219bede27b00cb33d5cc404173ad9a1fe09d976e3fe46d25c5020c971704163577622e2695ce SHA512 bc88ccfced8dafd57ff14e480a3a911f8d00243c2d022fdee07afb5e49a285b82871cd43e50d3960370b7225aa86ace191725411128969c9fc47e85f3ab8aa8b
diff --git a/dev-db/tdscpp/metadata.xml b/dev-db/tdscpp/metadata.xml
new file mode 100644
index 000000000..5cb4b7f96
--- /dev/null
+++ b/dev-db/tdscpp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mark@harmstone.com</email>
+ <name>Mark Harmstone</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">maharmstone/tdscpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/tdscpp/tdscpp-20240212.ebuild b/dev-db/tdscpp/tdscpp-20240212.ebuild
new file mode 100644
index 000000000..8d1c0da76
--- /dev/null
+++ b/dev-db/tdscpp/tdscpp-20240212.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ library to communicate with Microsoft SQL server"
+HOMEPAGE="https://github.com/maharmstone/tdscpp"
+SRC_URI="https://codeload.github.com/maharmstone/tdscpp/tar.gz/refs/tags/${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+IUSE="kerberos +ssl"
+
+DEPEND="dev-cpp/nlohmann_json
+ dev-libs/icu
+ kerberos? ( virtual/krb5 )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_KRB5="$(usex kerberos)"
+ -DWITH_OPENSSL="$(usex ssl)"
+ -DBUILD_SAMPLE=OFF
+ )
+
+ cmake_src_configure
+}