aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Zapparov <alexey@zapparov.com>2023-08-01 02:23:08 +0200
committerAlexey Zapparov <alexey@zapparov.com>2023-08-01 02:23:20 +0200
commit6284338105f1d4a476bea478f70c8289b13c79e9 (patch)
tree1eaf69b21d09ee56a613ac757019387ca9d5d1dd /dev-ruby
parentwww-apps/code-server-bin: drop 4.13.0-r1 (diff)
downloadguru-6284338105f1d4a476bea478f70c8289b13c79e9.tar.gz
guru-6284338105f1d4a476bea478f70c8289b13c79e9.tar.bz2
guru-6284338105f1d4a476bea478f70c8289b13c79e9.zip
dev-ruby/ruby-install: add 0.9.1
Signed-off-by: Alexey Zapparov <alexey@zapparov.com>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-install/Manifest1
-rw-r--r--dev-ruby/ruby-install/files/ruby-install-0.9.1-fix-version.patch13
-rw-r--r--dev-ruby/ruby-install/ruby-install-0.9.1.ebuild48
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/ruby-install/Manifest b/dev-ruby/ruby-install/Manifest
index 2701130057..59455c7430 100644
--- a/dev-ruby/ruby-install/Manifest
+++ b/dev-ruby/ruby-install/Manifest
@@ -1,2 +1,3 @@
DIST ruby-install-0.8.5.tar.gz 32904 BLAKE2B 6128d489c53c02b53b96f243a7c5fd3de2a360eac8ed7873c89cfafb229e611f77f3275e66bb1aef0ccad772029f7727c0e4a62c6dc74ec1780c7badd219cc52 SHA512 4f5546652e741eb4b1b72780a73e0b41b8bd212dd979e31124b8a1a96e9bbebdcb7951da20768b992776206a446b489214f2b1261255855760e2e3477118f8d7
DIST ruby-install-0.9.0.tar.gz 34536 BLAKE2B de44b380b47f1c194bd9c39e43527c48b61f051bc126b051d87ce23db7d5ed3c6f46a97ff454e847a47fe16535c15d5903839f07ed30446f0b2f0d063364961b SHA512 d40195519d4d49749e13fb9d1c2e8f6a4c4c7b1cb4c419ce737a2dc2f7f6fb80b0783626bfe4b4bdd642a189d6fd641a5a121a4fa661e8a7539b4eefa12435ae
+DIST ruby-install-0.9.1.tar.gz 35732 BLAKE2B b61d882d9f7a1c8e07b0b094689f6606f1a80fd03f334b2d6365e0a9b18a0ca6829ef0db009fa783821cfb58a13dc130d96a280775027a7d901eb599f0900b34 SHA512 48fdc6904b5ab7f4cb6f18385432edade88bf2f388ef167ab2752b51841a481fc0f1b735169b6ef50f2dd070e1e59c28d21c7a4aa8dabe292a668b5d41db52a7
diff --git a/dev-ruby/ruby-install/files/ruby-install-0.9.1-fix-version.patch b/dev-ruby/ruby-install/files/ruby-install-0.9.1-fix-version.patch
new file mode 100644
index 0000000000..040452eed2
--- /dev/null
+++ b/dev-ruby/ruby-install/files/ruby-install-0.9.1-fix-version.patch
@@ -0,0 +1,13 @@
+diff --git a/share/ruby-install/ruby-install.sh b/share/ruby-install/ruby-install.sh
+index 976c2277..a0457d9f 100644
+--- a/share/ruby-install/ruby-install.sh
++++ b/share/ruby-install/ruby-install.sh
+@@ -2,7 +2,7 @@
+
+ shopt -s extglob
+
+-ruby_install_version="0.9.0"
++ruby_install_version="0.9.1"
+ ruby_install_dir="${BASH_SOURCE[0]%/*}"
+ ruby_install_cache_dir="${XDG_CACHE_HOME:-$HOME/.cache}/ruby-install"
+
diff --git a/dev-ruby/ruby-install/ruby-install-0.9.1.ebuild b/dev-ruby/ruby-install/ruby-install-0.9.1.ebuild
new file mode 100644
index 0000000000..4e4057cefa
--- /dev/null
+++ b/dev-ruby/ruby-install/ruby-install-0.9.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Installs Ruby, JRuby, Rubinius, TruffleRuby (native / GraalVM), or mruby."
+HOMEPAGE="https://github.com/postmodern/ruby-install"
+SRC_URI="https://github.com/postmodern/ruby-install/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PROPERTIES="test_network"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=app-shells/bash-3.0:*"
+RDEPEND="${DEPEND}
+ sys-apps/grep
+ || ( >net-misc/wget-1.12 net-misc/curl )
+ dev-libs/openssl
+ app-arch/tar
+ app-arch/bzip2
+ app-arch/xz-utils
+ sys-devel/patch
+ || ( >=sys-devel/gcc-4.2 sys-devel/clang )"
+BDEPEND="test? ( dev-util/shunit2 )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-version.patch"
+)
+
+# BUG: `make check` fails: https://github.com/postmodern/ruby-install/issues/442
+src_test() {
+ emake test
+}
+
+src_prepare() {
+ default
+
+ sed -i Makefile -e "s/^VERSION=.\+$/VERSION=${PVR}/" \
+ || die "Cannot fix doc location to follow Gentoo/FHS guidelines"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}