aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMoritz Brunner <moritz.brunner+gentoo@posteo.de>2024-01-03 20:49:54 +0100
committerMoritz Brunner <moritz.brunner+gentoo@posteo.de>2024-01-03 20:54:28 +0100
commit14c6088d3f5b399441f27905cbe231b3cc619cb3 (patch)
tree763c995e792d0f2f3d6dc500c7dc5f09f62bfe3b /games-emulation
parentgui-apps/wbg: add codeberg upstream metadata (diff)
downloadguru-14c6088d3f5b399441f27905cbe231b3cc619cb3.tar.gz
guru-14c6088d3f5b399441f27905cbe231b3cc619cb3.tar.bz2
guru-14c6088d3f5b399441f27905cbe231b3cc619cb3.zip
games-emulation/yuzu: Replace inih with simpleini
inih was replaced upstream with simpleini for config file support. Closes: https://bugs.gentoo.org/920675 Closes: https://bugs.gentoo.org/918648 Signed-off-by: Moritz Brunner <moritz.brunner+gentoo@posteo.de>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/yuzu/yuzu-9999.ebuild7
1 files changed, 1 insertions, 6 deletions
diff --git a/games-emulation/yuzu/yuzu-9999.ebuild b/games-emulation/yuzu/yuzu-9999.ebuild
index 56db5e975..8e4293715 100644
--- a/games-emulation/yuzu/yuzu-9999.ebuild
+++ b/games-emulation/yuzu/yuzu-9999.ebuild
@@ -54,6 +54,7 @@ DEPEND="${RDEPEND}
"
BDEPEND="
>=dev-cpp/nlohmann_json-3.8.0
+ dev-cpp/simpleini
dev-cpp/robin-map
dev-util/glslang
discord? ( >=dev-libs/rapidjson-1.1.0 )
@@ -91,12 +92,6 @@ src_prepare() {
# temporary fix
sed -i -e '/Werror/d' src/CMakeLists.txt || die
- # Unbundle inih
- sed -i -e '/^if.*inih/,/^endif()/d' externals/CMakeLists.txt || die
- sed -i -e '1afind_package(PkgConfig REQUIRED)\npkg_check_modules(INIH REQUIRED INIReader)' \
- src/yuzu_cmd/CMakeLists.txt || die
- sed -i -e 's:inih/cpp/::' src/yuzu_cmd/config.cpp || die
-
# Unbundle mbedtls
sed -i -e '/mbedtls/d' -e '/^if (NOT MSVC)/,/endif()/d' externals/CMakeLists.txt || die
sed -i -e 's/mbedtls/& mbedcrypto mbedx509/' \