aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-29 00:59:20 +0400
committerVitaly Zdanevich <zdanevich.vitaly@ya.ru>2024-03-29 00:59:20 +0400
commit0dd83a44f34614db955258748241a7ddcfd74b02 (patch)
tree908ca6354d9b9224e82aca4394bc956c7febbf7b /games-rpg
parentnet-misc/xmrig-mo: add 6.21.2, remove old ebuilds, update metadata (diff)
downloadguru-0dd83a44f34614db955258748241a7ddcfd74b02.tar.gz
guru-0dd83a44f34614db955258748241a7ddcfd74b02.tar.bz2
guru-0dd83a44f34614db955258748241a7ddcfd74b02.zip
games-rpg/sacred-demo: new package
Signed-off-by: Vitaly Zdanevich <zdanevich.vitaly@ya.ru>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/sacred-demo/Manifest1
-rw-r--r--games-rpg/sacred-demo/metadata.xml8
-rw-r--r--games-rpg/sacred-demo/sacred-demo-1.0.0.ebuild47
3 files changed, 56 insertions, 0 deletions
diff --git a/games-rpg/sacred-demo/Manifest b/games-rpg/sacred-demo/Manifest
new file mode 100644
index 000000000..0a6df729d
--- /dev/null
+++ b/games-rpg/sacred-demo/Manifest
@@ -0,0 +1 @@
+DIST sacred-demo.tar.xz 215131736 BLAKE2B 1e2489bae7ea499877512a5da590e0fe7d7e029b7356428477b0c53060851ff192a881cfa3b30d8f6a9f52a95bb1eb94fde73a2abe05053bfde9032abaf35261 SHA512 ffc6033fda2e2356a938dacc35119dce448f4dddd11f9269a2050bd0b83ae92061b0b13233342a6d725a61e969c1eecff173ea1f5761a3ec65942e309abb2c8a
diff --git a/games-rpg/sacred-demo/metadata.xml b/games-rpg/sacred-demo/metadata.xml
new file mode 100644
index 000000000..812e586b9
--- /dev/null
+++ b/games-rpg/sacred-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Vitaly Zdanevich</name>
+ <email>zdanevich.vitaly@ya.ru</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-rpg/sacred-demo/sacred-demo-1.0.0.ebuild b/games-rpg/sacred-demo/sacred-demo-1.0.0.ebuild
new file mode 100644
index 000000000..63681e906
--- /dev/null
+++ b/games-rpg/sacred-demo/sacred-demo-1.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit wrapper
+
+DESCRIPTION="Like Diablo, isometric view, good rating, about a two hours of the gameplay"
+HOMEPAGE="https://en.wikipedia.org/wiki/Sacred_(video_game)"
+
+SRC_URI="https://archive.org/download/$PN.tar/$PN.tar.xz"
+
+KEYWORDS="~amd64"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+RESTRICT="strip"
+
+RDEPEND="
+ virtual/wine
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+
+ mkdir -p "$ED$/opt"
+
+ mkdir "$ED/opt" || die
+ mkdir -p "$ED/usr/bin/" || die
+ cp -r "$PN" "$ED/opt/$PN" || die
+
+ echo "cd /opt/$PN; WINEPREFIX=\$HOME/.wine-sacred/ wine /opt/$PN/Sacred.exe; cd -" > "$ED/usr/bin/$PN"
+ fperms +x "/usr/bin/$PN"
+ fperms 777 "/opt/$PN/"
+
+}
+
+pkg_postinst() {
+ einfo "More about the game:"
+ einfo "https://www.wikidata.org/wiki/Q1757845"
+ einfo ""
+ einfo "Buy the full game at https://store.steampowered.com/app/12320/Sacred_Gold/"
+ einfo ""
+ einfo "The game is installed to /opt/$PN - if you want to run it by another Wine or operating system"
+}