aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-04-28 01:18:34 +0200
committerJulien Roy <julien@jroy.ca>2024-05-13 18:18:20 -0400
commitd6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc (patch)
tree33de9196b9bf108bf4da7606b99327ba2c5f1af9 /games-util
parentdev-vcs/*: fix variable order (diff)
downloadguru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.tar.gz
guru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.tar.bz2
guru-d6ae7d0c076c6f3e25baddcc28d31b6e7b05f5cc.zip
games-*/*: fix variable order
I manually went through some entries for `pkgcheck scan -c VariableOrderCheck`. Misc updates: UnusedEclassesCheck RESTRICT+=" .." -> RESTRICT=".." Signed-off-by: Lucio Sauer <watermanpaint@posteo.net> Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild7
-rw-r--r--games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild9
-rw-r--r--games-util/gamehub/gamehub-0.16.0.1.ebuild9
-rw-r--r--games-util/gamehub/gamehub-0.16.3.2.ebuild9
-rw-r--r--games-util/itch-bin/itch-bin-25.5.1-r2.ebuild7
-rw-r--r--games-util/protonup/protonup-0.1.5.ebuild4
-rw-r--r--games-util/r2modman-bin/r2modman-bin-3.1.48.ebuild12
-rw-r--r--games-util/roll/roll-2.6.1.ebuild6
-rw-r--r--games-util/xivlauncher/xivlauncher-1.0.8.ebuild31
9 files changed, 45 insertions, 49 deletions
diff --git a/games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild b/games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild
index 77d044161..0e7afef93 100644
--- a/games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild
+++ b/games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild
@@ -14,15 +14,16 @@ SRC_URI="
https://raw.githubusercontent.com/bigbass1997/${PN}/master/lwjgl3/src/main/resources/libgdx32.png -> ${PN}-32.png
https://raw.githubusercontent.com/bigbass1997/${PN}/master/lwjgl3/src/main/resources/libgdx16.png -> ${PN}-16.png
"
-KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+
LICENSE="CC-BY-NC-SA-4.0"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
RDEPEND="virtual/jre:1.8"
BDEPEND="app-arch/unzip"
-S="${WORKDIR}"
-
src_unpack() {
default
cp "${DISTDIR}/${PN}"-{16,32,64,128}.png "${S}" || die
diff --git a/games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild b/games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild
index 25bbae463..3e3d66864 100644
--- a/games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild
+++ b/games-util/ProtonUp-Qt/ProtonUp-Qt-2.9.2.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-_app_id=net.davidotek.pupgui2
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=(python3_{9..12})
@@ -11,12 +10,15 @@ EPYTHON=python3
inherit distutils-r1 desktop xdg-utils
-SRC_URI="https://github.com/DavidoTek/ProtonUp-Qt/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+_app_id=net.davidotek.pupgui2
+
DESCRIPTION="Install and manage GE-Proton, Luxtorpeda & more for Steam Lutris and Heroic."
HOMEPAGE="https://davidotek.github.io/protonup-qt"
+SRC_URI="https://github.com/DavidoTek/ProtonUp-Qt/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
+KEYWORDS="~amd64"
RDEPEND="dev-python/steam
dev-python/requests
@@ -26,14 +28,11 @@ RDEPEND="dev-python/steam
dev-python/pyaml
dev-python/zstandard
"
-
DEPEND="${RDEPEND}
dev-util/desktop-file-utils
dev-libs/appstream-glib
"
-KEYWORDS="~amd64"
-
src_compile() {
appstream-util validate-relax --nonet "share/metainfo/$_app_id.appdata.xml"
desktop-file-validate "share/applications/$_app_id.desktop"
diff --git a/games-util/gamehub/gamehub-0.16.0.1.ebuild b/games-util/gamehub/gamehub-0.16.0.1.ebuild
index f5061b369..665cea402 100644
--- a/games-util/gamehub/gamehub-0.16.0.1.ebuild
+++ b/games-util/gamehub/gamehub-0.16.0.1.ebuild
@@ -7,15 +7,16 @@ VALA_MIN_API_VERSION="0.44"
inherit gnome2-utils meson vala xdg
-DESCRIPTION="GameHub is a unified library for all your games"
-HOMEPAGE="https://tkashkin.tk/projects/gamehub"
-
MY_PN="GameHub"
MY_PV="$(ver_rs 3 '-')-master"
MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="GameHub is a unified library for all your games"
+HOMEPAGE="https://tkashkin.tk/projects/gamehub"
SRC_URI="https://github.com/tkashkin/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -37,8 +38,6 @@ BDEPEND="
${RDEPEND}
$(vala_depend)"
-S="${WORKDIR}/${MY_P}"
-
src_prepare() {
default
vala_src_prepare
diff --git a/games-util/gamehub/gamehub-0.16.3.2.ebuild b/games-util/gamehub/gamehub-0.16.3.2.ebuild
index 4b07e2e73..acabc671c 100644
--- a/games-util/gamehub/gamehub-0.16.3.2.ebuild
+++ b/games-util/gamehub/gamehub-0.16.3.2.ebuild
@@ -5,15 +5,16 @@ EAPI=8
inherit gnome2-utils meson vala xdg
-DESCRIPTION="GameHub is a unified library for all your games"
-HOMEPAGE="https://tkashkin.github.io/projects/gamehub https://github.com/tkashkin/gamehub"
-
MY_PN="GameHub"
MY_PV="$(ver_rs 3 '-')-master"
MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="GameHub is a unified library for all your games"
+HOMEPAGE="https://tkashkin.github.io/projects/gamehub https://github.com/tkashkin/gamehub"
SRC_URI="https://github.com/tkashkin/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -35,8 +36,6 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="$(vala_depend)"
-S="${WORKDIR}/${MY_P}"
-
src_prepare() {
default
vala_setup
diff --git a/games-util/itch-bin/itch-bin-25.5.1-r2.ebuild b/games-util/itch-bin/itch-bin-25.5.1-r2.ebuild
index e81890c24..3dabe9b28 100644
--- a/games-util/itch-bin/itch-bin-25.5.1-r2.ebuild
+++ b/games-util/itch-bin/itch-bin-25.5.1-r2.ebuild
@@ -9,9 +9,12 @@ DESCRIPTION="itch.io game browser, installer and launcher"
HOMEPAGE="https://itch.io/"
SRC_URI="https://broth.itch.ovh/itch/linux-amd64/${PV}/archive/default -> ${P}.zip"
-KEYWORDS="~amd64"
+S="${WORKDIR}"
+
LICENSE="MIT"
SLOT="0"
+KEYWORDS="~amd64"
+
IUSE="system-ffmpeg"
BDEPEND="app-arch/unzip"
@@ -39,8 +42,6 @@ QA_PREBUILT="
!system-ffmpeg? ( opt/itch-bin/libffmpeg.so )
"
-S="${WORKDIR}"
-
src_install() {
local destdir="${EPREFIX}/opt/${PN}"
insinto "${destdir}"
diff --git a/games-util/protonup/protonup-0.1.5.ebuild b/games-util/protonup/protonup-0.1.5.ebuild
index 37f6612d2..dfc0b51fe 100644
--- a/games-util/protonup/protonup-0.1.5.ebuild
+++ b/games-util/protonup/protonup-0.1.5.ebuild
@@ -9,13 +9,13 @@ PYTHON_COMPAT=( python3_{9..12} )
EPYTHON=python3
inherit distutils-r1
-SRC_URI="https://github.com/AUNaseef/protonup/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
DESCRIPTION="Install and Update Proton-GE"
HOMEPAGE="https://github.com/AUNaseef/protonup"
+SRC_URI="https://github.com/AUNaseef/protonup/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-
KEYWORDS="~amd64 ~x86"
src_compile() {
diff --git a/games-util/r2modman-bin/r2modman-bin-3.1.48.ebuild b/games-util/r2modman-bin/r2modman-bin-3.1.48.ebuild
index e2a6b4e7c..ebd671ece 100644
--- a/games-util/r2modman-bin/r2modman-bin-3.1.48.ebuild
+++ b/games-util/r2modman-bin/r2modman-bin-3.1.48.ebuild
@@ -6,6 +6,9 @@ EAPI=8
M_PN=r2modman
inherit desktop xdg
+
+DESCRIPTION="A simple and easy to use mod manager for several games using Thunderstore"
+HOMEPAGE="https://github.com/ebkr/r2modmanPlus"
SRC_URI="
https://github.com/ebkr/${M_PN}Plus/releases/download/v${PV}/${M_PN}-${PV}.tar.gz -> ${P}.tar.gz
https://raw.githubusercontent.com/ebkr/r2modmanPlus/v${PV}/src/assets/icon/16x16.png -> ${P}-16x16.png
@@ -17,11 +20,12 @@ SRC_URI="
https://raw.githubusercontent.com/ebkr/r2modmanPlus/v${PV}/src/assets/icon/192x192.png -> ${P}-192x192.png
https://raw.githubusercontent.com/ebkr/r2modmanPlus/v${PV}/src/assets/icon/256x256.png -> ${P}-256x256.png
"
-DESCRIPTION="A simple and easy to use mod manager for several games using Thunderstore"
-HOMEPAGE="https://github.com/ebkr/r2modmanPlus"
+
+S="${WORKDIR}"
LICENSE="MIT"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
RDEPEND="
net-dns/c-ares
@@ -41,10 +45,6 @@ RDEPEND="
app-arch/snappy
"
-KEYWORDS="~amd64 ~x86"
-
-S="${WORKDIR}"
-
QA_PREBUILT="
/opt/r2modman/chrome-sandbox
/opt/r2modman/libEGL.so
diff --git a/games-util/roll/roll-2.6.1.ebuild b/games-util/roll/roll-2.6.1.ebuild
index e6e254d32..c55540cd5 100644
--- a/games-util/roll/roll-2.6.1.ebuild
+++ b/games-util/roll/roll-2.6.1.ebuild
@@ -8,10 +8,10 @@ HOMEPAGE="http://matteocorti.github.io/roll/"
SRC_URI="https://github.com/matteocorti/${PN}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-2"
-IUSE="test"
SLOT="0"
KEYWORDS="~amd64"
-RDEPEND="${DEPEND}"
-
+IUSE="test"
RESTRICT="!test? ( test )"
+
+RDEPEND="${DEPEND}"
diff --git a/games-util/xivlauncher/xivlauncher-1.0.8.ebuild b/games-util/xivlauncher/xivlauncher-1.0.8.ebuild
index 70e7097fe..7da3e93c0 100644
--- a/games-util/xivlauncher/xivlauncher-1.0.8.ebuild
+++ b/games-util/xivlauncher/xivlauncher-1.0.8.ebuild
@@ -234,9 +234,22 @@ vortice.mathematics@1.4.25
inherit dotnet-pkg desktop xdg
-DESCRIPTION="Custom Launcher for Final Fantasy XIV Online (Crossplatform rewrite)"
+XIVQL_COMMIT="020dde9d504f879a56b08fde570bcb4b5772ed3e"
+DESCRIPTION="Custom Launcher for Final Fantasy XIV Online (Crossplatform rewrite)"
HOMEPAGE="https://github.com/goatcorp/XIVLauncher.Core/"
+SRC_URI="
+ https://github.com/goatcorp/XIVLauncher.Core/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/goatcorp/FFXIVQuickLauncher/archive/${XIVQL_COMMIT}.tar.gz
+ -> FFXIVQuickLauncher-${XIVQL_COMMIT}.tar.gz
+ ${NUGET_URIS}
+"
+
+S="${WORKDIR}/XIVLauncher.Core-${PV}/src"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
IUSE="+aria2 +libsecret"
@@ -259,24 +272,8 @@ RDEPEND="
x11-libs/libSM
"
-XIVQL_COMMIT="020dde9d504f879a56b08fde570bcb4b5772ed3e"
-
-SRC_URI="
- https://github.com/goatcorp/XIVLauncher.Core/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/goatcorp/FFXIVQuickLauncher/archive/${XIVQL_COMMIT}.tar.gz
- -> FFXIVQuickLauncher-${XIVQL_COMMIT}.tar.gz
- ${NUGET_URIS}
-"
-
-S="${WORKDIR}/XIVLauncher.Core-${PV}/src"
-
DOTNET_PKG_PROJECTS=( "${S}/XIVLauncher.Core/XIVLauncher.Core.csproj" )
-LICENSE="GPL-3"
-
-SLOT="0"
-KEYWORDS="~amd64"
-
src_prepare() {
rmdir "${WORKDIR}/XIVLauncher.Core-${PV}/lib/FFXIVQuickLauncher" || die
mv "${WORKDIR}/FFXIVQuickLauncher-${XIVQL_COMMIT}" \