aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-07-05 20:54:52 +0200
committerPascal Jäger <pascal.jaeger@leimstift.de>2024-07-05 20:55:16 +0200
commita01a7426de719d1b36d4dae4caaa0a65f9ade610 (patch)
treefe557dd0caa7466bd5738589f28c2c9604d68bee /gui-apps
parentgui-apps/nwg-shell: drop 0.5.33 (diff)
downloadguru-a01a7426de719d1b36d4dae4caaa0a65f9ade610.tar.gz
guru-a01a7426de719d1b36d4dae4caaa0a65f9ade610.tar.bz2
guru-a01a7426de719d1b36d4dae4caaa0a65f9ade610.zip
gui-apps/nwg-shell: add 0.5.36
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/nwg-shell/Manifest1
-rw-r--r--gui-apps/nwg-shell/nwg-shell-0.5.36.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/gui-apps/nwg-shell/Manifest b/gui-apps/nwg-shell/Manifest
index 1a475b1fa..5a0175314 100644
--- a/gui-apps/nwg-shell/Manifest
+++ b/gui-apps/nwg-shell/Manifest
@@ -1,2 +1,3 @@
DIST nwg-shell-0.5.34.tar.gz 2181853 BLAKE2B e85f59a871d9b3e485e3f6ecfb84e1c87a00f9e4814386d3b8be83a15c8ce617ab3a09c2948763d8efd4278d9411c59ceae68aee010252113ee53ae8b891b29e SHA512 95face93d593c0a2c2e1e7631b00e67141c8dc2651248778773d3bbf4aa5b207952e5783a496e6a539dcca327d0ce795ca4d778c020000909dd568541cc0f258
DIST nwg-shell-0.5.35.tar.gz 2181827 BLAKE2B cd2969e0deecee1f43bdf25218203cd86a4ce828c24ad3a931d26d191a003c47093c5e919f3bd27ae85f4899ddea316596b066227c7c1edb978a03aae7076ada SHA512 b9a9dea24d8d0b7d1eb77d69fd33a70868de49113a25d79be45411862375ef0968083738b3081496580661997c9793af66bfa09b622b0fab4b90ac68b6d8c04b
+DIST nwg-shell-0.5.36.tar.gz 2181809 BLAKE2B d540bf948c9a02a3b880738d04ff7a9581e706bb071c618a0f3a86a4d00c607eb9fe32dba7de0f7338f531c8e600e6a89ddb9ffc5ed9e5ae1ffe9561e2165baf SHA512 2eb5745f70048ce02b5c6e3b08848f0d030e5a8ff16fc3b16caa8fd59b09ccf5009796d4550d2f3dec96339625528e5f5d7dbb5198d529ababef8e37569f5071
diff --git a/gui-apps/nwg-shell/nwg-shell-0.5.36.ebuild b/gui-apps/nwg-shell/nwg-shell-0.5.36.ebuild
new file mode 100644
index 000000000..b2a468557
--- /dev/null
+++ b/gui-apps/nwg-shell/nwg-shell-0.5.36.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="libraries an common functions for the nwg-shell project"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell"
+SRC_URI="https://github.com/nwg-piotr/nwg-shell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ gui-apps/grim
+ gui-apps/swappy
+ gui-apps/slurp
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ default
+ dobin scripts/*
+}
+
+pkg_postinst() {
+ elog "To install nwg-shell for the current user, run"
+ elog "nwg-shell-installer -w (for sway) or"
+ elog "nwg-shell-installer -w -hypr (for hyprland)"
+}