aboutsummaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorTheo Donacik <theodonacik@gmail.com>2024-05-05 11:14:49 -0400
committerTheo Donacik <theodonacik@gmail.com>2024-05-05 11:14:49 -0400
commit97a6a2508f8aa749c281edeb94b8ba8d3b1ee516 (patch)
tree356821df03c82891df6cd0b843467e4836bab15c /gui-wm
parentdev-util/eclipse-paralell-bin: drop old 4.27 (diff)
downloadguru-97a6a2508f8aa749c281edeb94b8ba8d3b1ee516.tar.gz
guru-97a6a2508f8aa749c281edeb94b8ba8d3b1ee516.tar.bz2
guru-97a6a2508f8aa749c281edeb94b8ba8d3b1ee516.zip
gui-wm/scenefx: new package, add 0.1
Signed-off-by: Theo Donacik <theodonacik@gmail.com>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/scenefx/Manifest1
-rw-r--r--gui-wm/scenefx/scenefx-0.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/gui-wm/scenefx/Manifest b/gui-wm/scenefx/Manifest
new file mode 100644
index 0000000000..add0c70f53
--- /dev/null
+++ b/gui-wm/scenefx/Manifest
@@ -0,0 +1 @@
+DIST scenefx-0.1.tar.gz 107137 BLAKE2B 980ccc3040584f83e3c911975f194abb50e05474ab73e1fef8ca2884a1f4a89436ec8838931ce7e1a1ca4d4df2bf746c9141fef45baad9f602e1327a70ac6ba3 SHA512 6f145ff44c799e61501d63306e3df97bb8376a8cab12ff77cdd743de3784f65c584a297f056008d88e7cd514849a750662023ce53959b9d005a1417f3a5ca1dc
diff --git a/gui-wm/scenefx/scenefx-0.1.ebuild b/gui-wm/scenefx/scenefx-0.1.ebuild
new file mode 100644
index 0000000000..3af25dbdff
--- /dev/null
+++ b/gui-wm/scenefx/scenefx-0.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="A replacement for the wlroots scene API with eye-candy effects."
+HOMEPAGE="https://github.com/wlrfx/scenefx"
+
+SRC_URI="https://github.com/wlrfx/scenefx/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="examples liftoff +libinput +drm vulkan x11-backend xcb-errors X"
+REQUIRED_USE="
+ xcb-errors? ( || ( x11-backend X ) )
+"
+
+DEPEND="
+ >=dev-libs/wayland-1.22.0
+ >=x11-libs/libdrm-2.4.114
+ media-libs/mesa[egl(+),gles2(+)]
+ >=x11-libs/pixman-0.42.0
+ media-libs/libglvnd
+ x11-libs/libxkbcommon
+ drm? (
+ media-libs/libdisplay-info
+ sys-apps/hwdata
+ liftoff? ( >=dev-libs/libliftoff-0.4 )
+ )
+ libinput? ( >=dev-libs/libinput-1.14.0:= )
+ x11-backend? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-renderutil
+ )
+ vulkan? (
+ dev-util/glslang:=
+ dev-util/vulkan-headers
+ media-libs/vulkan-loader
+ )
+ xcb-errors? ( x11-libs/xcb-util-errors )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm
+ x11-base/xwayland
+ )
+"
+DEPEND+="
+ >=gui-libs/wlroots-0.17:=[X?]
+ <gui-libs/wlroots-0.18:=[X?]
+"
+
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ >=dev-build/meson-0.59.0
+ virtual/pkgconfig
+ dev-build/ninja
+"
+
+src_configure() {
+ local backends=(
+ $(usev drm)
+ $(usev libinput)
+ $(usev x11-backend 'x11')
+ )
+ local meson_backends=$(IFS=','; echo "${backends[*]}")
+ local emesonargs=(
+ -Drenderers=$(usex vulkan 'gles2,vulkan' gles2)
+ $(meson_feature X xwayland)
+ $(meson_feature xcb-errors)
+ $(meson_use examples)
+ -Dbackends=${meson_backends}
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}