aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuhang Zeng <unlsycn@unlsycn.com>2024-07-30 23:39:11 +0800
committerYuhang Zeng <unlsycn@unlsycn.com>2024-07-30 23:41:05 +0800
commit450eaab2218a07c3f4e831504a4dc16dd3ba259d (patch)
tree0158a6432ca748acf33ddfd6f3530460f0d20f7b /media-sound/pamixer
parentdev-ml/chrome-trace: new package, add 3.16.0 (diff)
downloadguru-450eaab2218a07c3f4e831504a4dc16dd3ba259d.tar.gz
guru-450eaab2218a07c3f4e831504a4dc16dd3ba259d.tar.bz2
guru-450eaab2218a07c3f4e831504a4dc16dd3ba259d.zip
media-sound/pamixer: new package, add 1.6, 9999
Signed-off-by: Yuhang Zeng <unlsycn@unlsycn.com>
Diffstat (limited to 'media-sound/pamixer')
-rw-r--r--media-sound/pamixer/Manifest1
-rw-r--r--media-sound/pamixer/metadata.xml10
-rw-r--r--media-sound/pamixer/pamixer-1.6.ebuild28
-rw-r--r--media-sound/pamixer/pamixer-9999.ebuild28
4 files changed, 67 insertions, 0 deletions
diff --git a/media-sound/pamixer/Manifest b/media-sound/pamixer/Manifest
new file mode 100644
index 000000000..2f7d3fb51
--- /dev/null
+++ b/media-sound/pamixer/Manifest
@@ -0,0 +1 @@
+DIST pamixer-1.6.tar.gz 18574 BLAKE2B f7951102b2605d31886a7d76f608e3a349ab760a0995e81514dfc978d92e322ce83abb733364169317b996494bc898c1a81efc71805a62b61f9817c743a31e79 SHA512 c01b7c4184901955bff82aaeef0cde7f0b613e6ebff1158b3603f2835e13590a9353920a430598a3cde5c305a7316a78e302186bf4d3bf458133262578b42eb3
diff --git a/media-sound/pamixer/metadata.xml b/media-sound/pamixer/metadata.xml
new file mode 100644
index 000000000..b1b113fad
--- /dev/null
+++ b/media-sound/pamixer/metadata.xml
@@ -0,0 +1,10 @@
+<pkgmetadata>
+ <maintainer type="person">
+ <email>unlsycn@unlsycn.com</email>
+ <name>unlsycn</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cdemoulins/pamixer</remote-id>
+ </upstream>
+ <longdescription lang="en">pamixer is like amixer but for pulseaudio. It can control the volume levels of the sinks.</longdescription>
+</pkgmetadata>
diff --git a/media-sound/pamixer/pamixer-1.6.ebuild b/media-sound/pamixer/pamixer-1.6.ebuild
new file mode 100644
index 000000000..88af5d4dd
--- /dev/null
+++ b/media-sound/pamixer/pamixer-1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Pulseaudio command line mixer."
+HOMEPAGE="https://github.com/cdemoulins/pamixer"
+
+inherit meson
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cdemoulins/pamixer"
+else
+ SRC_URI="https://github.com/cdemoulins/pamixer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+RDEPEND="
+ dev-libs/cxxopts
+ media-libs/libpulse
+"
+
+DEPEND="${RDEPEND}"
diff --git a/media-sound/pamixer/pamixer-9999.ebuild b/media-sound/pamixer/pamixer-9999.ebuild
new file mode 100644
index 000000000..88af5d4dd
--- /dev/null
+++ b/media-sound/pamixer/pamixer-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Pulseaudio command line mixer."
+HOMEPAGE="https://github.com/cdemoulins/pamixer"
+
+inherit meson
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cdemoulins/pamixer"
+else
+ SRC_URI="https://github.com/cdemoulins/pamixer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+RDEPEND="
+ dev-libs/cxxopts
+ media-libs/libpulse
+"
+
+DEPEND="${RDEPEND}"