aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDale Sweeney <agooglygooglr@gmail.com>2024-06-12 14:16:50 -0400
committerDale Sweeney <agooglygooglr@gmail.com>2024-06-12 14:16:50 -0400
commitdee7671f58a4861bfbaf975fb349e6f5792ff651 (patch)
tree66aa733ed4705cb599f631129f7bb08993a4a125 /media-video
parentRevert "media-video/*:" inappropriate GCO (diff)
downloadguru-dee7671f58a4861bfbaf975fb349e6f5792ff651.tar.gz
guru-dee7671f58a4861bfbaf975fb349e6f5792ff651.tar.bz2
guru-dee7671f58a4861bfbaf975fb349e6f5792ff651.zip
media-video/*:
Signed-off-by: Dale Sweeney <agooglygooglr@gmail.com> Add ebuilds for gpu-screen-recorder and its GUI front-end
Diffstat (limited to 'media-video')
-rw-r--r--media-video/gpu-screen-recorder-gtk/gpu-screen-recorder-gtk-9999.ebuild27
-rw-r--r--media-video/gpu-screen-recorder/gpu-screen-recorder-9999.ebuild42
2 files changed, 69 insertions, 0 deletions
diff --git a/media-video/gpu-screen-recorder-gtk/gpu-screen-recorder-gtk-9999.ebuild b/media-video/gpu-screen-recorder-gtk/gpu-screen-recorder-gtk-9999.ebuild
new file mode 100644
index 0000000000..f62192f555
--- /dev/null
+++ b/media-video/gpu-screen-recorder-gtk/gpu-screen-recorder-gtk-9999.ebuild
@@ -0,0 +1,27 @@
+EAPI=8
+
+inherit meson git-r3
+
+EGIT_REPO_URI="https://repo.dec05eba.com/gpu-screen-recorder-gtk"
+
+DESCRIPTION="GTK frontend for gpu-screen-recorder."
+HOMEPAGE="https://git.dec05eba.com/gpu-screen-recorder-gtk/about"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm64"
+
+DEPEND="
+ x11-libs/gtk+:3
+ dev-libs/libayatana-appindicator
+ media-video/gpu-screen-recorder
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_configure() {
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
diff --git a/media-video/gpu-screen-recorder/gpu-screen-recorder-9999.ebuild b/media-video/gpu-screen-recorder/gpu-screen-recorder-9999.ebuild
new file mode 100644
index 0000000000..bdeefe769a
--- /dev/null
+++ b/media-video/gpu-screen-recorder/gpu-screen-recorder-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson git-r3
+
+EGIT_REPO_URI="https://repo.dec05eba.com/gpu-screen-recorder"
+
+DESCRIPTION="A screen recorder that has minimal impact on system performance, similar to shadowplay on Windows."
+HOMEPAGE="https://git.dec05eba.com/gpu-screen-recorder/about"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm64"
+IUSE="+filecaps systemd"
+
+DEPEND="
+ media-video/ffmpeg
+ media-libs/libglvnd
+ x11-libs/libXcomposite
+ x11-libs/libXrandr
+ x11-libs/libXfixes
+ media-libs/libpulse
+ media-libs/libva
+ x11-libs/libdrm
+ sys-libs/libcap
+ dev-libs/wayland
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemd=$(usex filecaps true none)
+ -Dcapabilities=$(usex systemd true none)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}