aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2024-02-04 13:25:15 -0500
committerPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2024-02-04 13:25:47 -0500
commit84800651d6e7c67eea3b1d0519c2365af93fd5ca (patch)
tree4ddab8079a66aef15c8e996fa34c12aae213acbf /net-mail
parentx11-terms/rio: keyword 0.0.34 for ~arm64 (diff)
downloadguru-84800651d6e7c67eea3b1d0519c2365af93fd5ca.tar.gz
guru-84800651d6e7c67eea3b1d0519c2365af93fd5ca.tar.bz2
guru-84800651d6e7c67eea3b1d0519c2365af93fd5ca.zip
net-mail/dovecot-fts-xapian: add 1.5.9
Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot-fts-xapian/Manifest1
-rw-r--r--net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.9.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-mail/dovecot-fts-xapian/Manifest b/net-mail/dovecot-fts-xapian/Manifest
index 2478c7c46..5dd28a984 100644
--- a/net-mail/dovecot-fts-xapian/Manifest
+++ b/net-mail/dovecot-fts-xapian/Manifest
@@ -1,3 +1,4 @@
DIST dovecot-fts-xapian-1.5.4.tar.gz 33101 BLAKE2B f2bf7c2cee8930cb8791035d434468537decd72f0643b308f437ad634affa555c486ac4524a1b63b7cc06304e77c431f1e846497b6080c07911a82c20c602c8d SHA512 773579959c79142ab3a24ceaa7da7fd68a9c7dde4439bd613112fc02f4b23d4d7fd258563f771dbe06db4000f9be6a219bd88b07f57521ae45246029af58570d
DIST dovecot-fts-xapian-1.5.5.tar.gz 33228 BLAKE2B b8e86b3655a6b7291961cfbd39d6ef93ab2e2fbb049e97ebd07b473eb5fc5ecf91950343adfa9c267791442d581ebea47416d8e674d7f3019091fbd69b6e60f1 SHA512 229362207bfa7bb13b1ded4d8b2a2aef7a4a72306e140dc4bd5778991220b27d296ca3659993856f83c80c437f7feadebad1e3ac06f8120a6e45b69f6dbb1ecb
DIST dovecot-fts-xapian-1.5.7.tar.gz 33594 BLAKE2B 5d83cf5292ecf7d7245a56d21587302ea8c3bc5b0374c5c77013059fa66e4d187bb26b9c1d928e8ad324d235a79bd97a6878086fc19b493b1aeae1a312bceaf1 SHA512 eb3b7e19ba522dd9e9c2952c3022b15249889c814e8a90b50836526ab5000b26e0e835b71d3a4439f03d5399277b70a3ffeb366ca42061b647ab8ce251268c3b
+DIST dovecot-fts-xapian-1.5.9.tar.gz 34220 BLAKE2B 8cf0772122d5dd8cf25fa2e8a5c02c8a315fdf4fbd346db3d01e78aa3e1116d42fbf30c155a364e064bd2ea4e9b67a48a69b3a3dada2c471c550f1d4fabbc8bd SHA512 e5961e5f6aeed6efabf456487307dfd09e255077e8c2c3af6c390b73b48dd2613f09ad4dfcd64974a91463a05a55078edfb7368d8c01ce0a839847823507b91f
diff --git a/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.9.ebuild b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.9.ebuild
new file mode 100644
index 000000000..9e8a22927
--- /dev/null
+++ b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.5.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Dovecot FTS plugin backed by Xapian"
+HOMEPAGE="https://github.com/grosjo/fts-xapian"
+SRC_URI="https://github.com/grosjo/fts-xapian/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/fts-xapian-${PV}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ >=dev-libs/xapian-1.4:=
+ net-mail/dovecot:=
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ ${FILESDIR}/bug-887887_allow-O2-override.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Disable hardening so CFLAGS are left up to the Gentoo user
+ # https://bugs.gentoo.org/888751
+ econf \
+ --enable-hardening=no \
+ --with-dovecot="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+ $( use_enable static-libs static )
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}