aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrettalcox <brettalcox@gmail.com>2024-05-10 19:33:33 -0500
committerbrettalcox <brettalcox@gmail.com>2024-05-10 19:33:33 -0500
commit8fb5c8d70069c94b06c41f40fad1da97513abf2a (patch)
tree13a27b03246860f4b726e97e1945d49d47af2ab1 /net-news
parentmedia-sound/nulloy: skin version bump (diff)
downloadguru-8fb5c8d70069c94b06c41f40fad1da97513abf2a.tar.gz
guru-8fb5c8d70069c94b06c41f40fad1da97513abf2a.tar.bz2
guru-8fb5c8d70069c94b06c41f40fad1da97513abf2a.zip
net-news/gfeeds: add r2 to fix lxml module
Signed-off-by: brettalcox <brettalcox@gmail.com>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/gfeeds/gfeeds-2.2.0-r2.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/net-news/gfeeds/gfeeds-2.2.0-r2.ebuild b/net-news/gfeeds/gfeeds-2.2.0-r2.ebuild
new file mode 100644
index 000000000..4b5ede222
--- /dev/null
+++ b/net-news/gfeeds/gfeeds-2.2.0-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_11 )
+
+inherit gnome2-utils meson python-single-r1
+
+DESCRIPTION="An RSS/Atom feed reader for GNOME."
+HOMEPAGE="https://gitlab.gnome.org/World/gfeeds"
+SRC_URI="https://gitlab.gnome.org/World/gfeeds/-/archive/${PV}/${P}.tar.bz2"
+
+# This fixes 1 syntax-related compilation error and syntax warnings (usage of $)
+PATCHES="${FILESDIR}/${P}-blueprint-0.80-fix.patch"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/lxml-html-clean[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/readability-lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ dev-util/blueprint-compiler
+ gui-libs/gtk:4
+ gui-libs/libadwaita
+ net-libs/syndication-domination[python]
+ net-libs/webkit-gtk:6
+"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-build/meson-0.58"
+
+src_configure() {
+ local emesonargs=(
+ --prefix=/usr
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/gfeeds
+ python_optimize "${ED}"/usr
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}