aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-07-27 11:45:14 +0200
committerFilip Kobierski <fkobi@pm.me>2024-07-27 11:45:14 +0200
commitaedc02ff3297b1d82263925c6a5d79188f7b5dbd (patch)
tree6c35df0a9e00a5ad83e7cad98bee9f662d693007 /net-p2p
parentnet-p2p/monero: cleaning and general improvements (diff)
downloadguru-aedc02ff3297b1d82263925c6a5d79188f7b5dbd.tar.gz
guru-aedc02ff3297b1d82263925c6a5d79188f7b5dbd.tar.bz2
guru-aedc02ff3297b1d82263925c6a5d79188f7b5dbd.zip
net-p2p/monero: add 0.18.3.3-r2
With patch to allow for newer versions of miniupnpc Signed-off-by: Filip Kobierski <fkobi@pm.me>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/monero/files/monero-0.18.3.3-miniupnp-api-18.patch30
-rw-r--r--net-p2p/monero/monero-0.18.3.3-r2.ebuild123
2 files changed, 153 insertions, 0 deletions
diff --git a/net-p2p/monero/files/monero-0.18.3.3-miniupnp-api-18.patch b/net-p2p/monero/files/monero-0.18.3.3-miniupnp-api-18.patch
new file mode 100644
index 0000000000..d281f60ec0
--- /dev/null
+++ b/net-p2p/monero/files/monero-0.18.3.3-miniupnp-api-18.patch
@@ -0,0 +1,30 @@
+diff --git a/src/p2p/net_node.inl b/src/p2p/net_node.inl
+index 30e3d31b9..c49783e1c 100644
+--- a/src/p2p/net_node.inl
++++ b/src/p2p/net_node.inl
+@@ -2989,7 +2989,12 @@ namespace nodetool
+ UPNPUrls urls;
+ IGDdatas igdData;
+ char lanAddress[64];
++#if MINIUPNPC_API_VERSION > 17
++ char wanAddress[64];
++ result = UPNP_GetValidIGD(deviceList, &urls, &igdData, lanAddress, sizeof lanAddress, wanAddress, sizeof(wanAddress));
++#else
+ result = UPNP_GetValidIGD(deviceList, &urls, &igdData, lanAddress, sizeof lanAddress);
++#endif
+ freeUPNPDevlist(deviceList);
+ if (result > 0) {
+ if (result == 1) {
+@@ -3057,7 +3062,12 @@ namespace nodetool
+ UPNPUrls urls;
+ IGDdatas igdData;
+ char lanAddress[64];
++#if MINIUPNPC_API_VERSION > 17
++ char wanAddress[64];
++ result = UPNP_GetValidIGD(deviceList, &urls, &igdData, lanAddress, sizeof lanAddress, wanAddress, sizeof(wanAddress));
++#else
+ result = UPNP_GetValidIGD(deviceList, &urls, &igdData, lanAddress, sizeof lanAddress);
++#endif
+ freeUPNPDevlist(deviceList);
+ if (result > 0) {
+ if (result == 1) {
diff --git a/net-p2p/monero/monero-0.18.3.3-r2.ebuild b/net-p2p/monero/monero-0.18.3.3-r2.ebuild
new file mode 100644
index 0000000000..2b6b6e997e
--- /dev/null
+++ b/net-p2p/monero/monero-0.18.3.3-r2.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake systemd
+
+DESCRIPTION="The secure, private, untraceable cryptocurrency"
+HOMEPAGE="https://github.com/monero-project/monero"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/monero-project/monero.git"
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/monero-project/monero/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="BSD MIT"
+SLOT="0"
+IUSE="+daemon hw-wallet readline +tools +wallet-cli +wallet-rpc"
+REQUIRED_USE="|| ( daemon tools wallet-cli wallet-rpc )"
+RESTRICT="test"
+
+DEPEND="
+ acct-group/monero
+ acct-user/monero
+ <dev-libs/boost-1.85:=[nls]
+ dev-libs/libsodium:=
+ dev-libs/openssl:=
+ dev-libs/randomx
+ dev-libs/rapidjson
+ dev-libs/supercop
+ net-dns/unbound:=[threads]
+ net-libs/czmq:=
+ net-libs/miniupnpc:=
+ readline? ( sys-libs/readline:0= )
+ hw-wallet? (
+ dev-libs/hidapi
+ dev-libs/protobuf:=
+ virtual/libusb:1
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.18.3.3-unbundle-dependencies.patch"
+ "${FILESDIR}/${PN}-0.18.3.3-miniupnp-api-18.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ # TODO: Update CMake to install built libraries (help wanted)
+ -DBUILD_SHARED_LIBS=OFF
+ -DMANUAL_SUBMODULES=ON
+ -DUSE_DEVICE_TREZOR=$(usex hw-wallet ON OFF)
+ )
+
+ use elibc_musl && mycmakeargs+=( -DSTACK_TRACE=OFF )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ local targets=()
+ use daemon && targets+=(daemon)
+ use tools && targets+=(blockchain_{ancestry,blackball,db,depth,export,import,prune,prune_known_spent_data,stats,usage})
+ use wallet-cli && targets+=(simplewallet)
+ use wallet-rpc && targets+=(wallet_rpc_server)
+ cmake_build ${targets[@]}
+}
+
+src_install() {
+ einstalldocs
+
+ # Install all binaries.
+ find "${BUILD_DIR}/bin/" -type f -executable -print0 |
+ while IFS= read -r -d '' line; do
+ dobin "$line"
+ done
+
+ if use daemon; then
+ dodoc utils/conf/monerod.conf
+
+ # data-dir
+ keepdir /var/lib/monero
+ fowners monero:monero /var/lib/monero
+ fperms 0755 /var/lib/monero
+
+ # log-file dir
+ keepdir /var/log/monero
+ fowners monero:monero /var/log/monero
+ fperms 0755 /var/log/monero
+
+ # /etc/monero/monerod.conf
+ insinto /etc/monero
+ doins "${FILESDIR}/monerod.conf"
+
+ # OpenRC
+ newconfd "${FILESDIR}/monerod.confd" monerod
+ newinitd "${FILESDIR}/monerod.initd" monerod
+
+ # systemd
+ systemd_dounit "${FILESDIR}/monerod.service"
+ fi
+}
+
+pkg_postinst() {
+ if use daemon; then
+ elog "Start the Monero P2P daemon as a system service with"
+ elog "'rc-service monerod start'. Enable it at startup with"
+ elog "'rc-update add monerod default'."
+ elog
+ elog "Run monerod status as any user to get sync status and other stats."
+ elog
+ elog "The Monero blockchain can take up a lot of space (200 GiB) and is stored"
+ elog "in /var/lib/monero by default. You may want to enable pruning by adding"
+ elog "'prune-blockchain=1' to /etc/monero/monerod.conf to prune the blockchain"
+ elog "or move the data directory to another disk."
+ fi
+}